Bug 1575939 - systemd-udev-settle.service hangs for some minutes on each boot after upgrade to F28
Summary: systemd-udev-settle.service hangs for some minutes on each boot after upgrade...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 10:49 UTC by Cajus Pollmeier
Modified: 2018-05-09 14:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 14:53:00 UTC
Type: Bug


Attachments (Terms of Use)
Output of dmesg (132.16 KB, text/plain)
2018-05-08 10:49 UTC, Cajus Pollmeier
no flags Details

Description Cajus Pollmeier 2018-05-08 10:49:35 UTC
Created attachment 1433128 [details]
Output of dmesg

Description of problem:

After upgrading to F28, the system boots very slow and hangs displaying

(1 of 3) A start job is running for Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling
(2 of 3) A start job is running for dev-mapper-fedora\x2dhome.device
(3 of 3) A start job is running for udev Wait for Complete Device Initialization

at the console. Further investigation via systemctl blame lead me to the "systemd-udev-settle.service" which seems to fail:

# systemctl status systemd-udev-settle
● systemd-udev-settle.service - udev Wait for Complete Device Initialization
   Loaded: loaded (/usr/lib/systemd/system/systemd-udev-settle.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2018-05-07 11:40:27 CEST; 24h ago
     Docs: man:udev(7)
           man:systemd-udevd.service(8)
 Main PID: 810 (code=exited, status=1/FAILURE)

Mai 07 11:38:26 statler systemd[1]: Starting udev Wait for Complete Device Initialization...
Mai 07 11:40:27 statler systemd[1]: systemd-udev-settle.service: Main process exited, code=exited, status=1/FAILURE
Mai 07 11:40:27 statler systemd[1]: systemd-udev-settle.service: Failed with result 'exit-code'.
Mai 07 11:40:27 statler systemd[1]: Failed to start udev Wait for Complete Device Initialization.

This happens on a standard Dell XPS with SSD, LVM and crypted disk upgraded from F27.

Version-Release number of selected component (if applicable):


How reproducible:

Every boot time.

Actual results:

I've to wait ~3 minutes until the system comes up and I can log in.

Expected results:

It's booting as quick as it did on F27. Or even faster ;-)

Additional info:

I've attached a dmesg. If there's more information I can provide, just tell me.

Comment 1 Cajus Pollmeier 2018-05-09 14:53:00 UTC
It turned out that it was a high-dpi left over udev rule that caused that.


Note You need to log in before you can comment on or make changes to this bug.