Bug 1575999 - History of actions of content views missing after upgrade to 6.3
Summary: History of actions of content views missing after upgrade to 6.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.3.1
Hardware: All
OS: Linux
unspecified
high
Target Milestone: Unspecified
Assignee: Andrew Kofink
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2018-05-08 13:55 UTC by Julio Entrena Perez
Modified: 2019-08-12 14:05 UTC (History)
5 users (show)

Fixed In Version: tfm-rubygem-katello-3.4.5.75-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1596357 (view as bug list)
Environment:
Last Closed: 2018-08-22 20:07:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of UI timestamp intact after upgrade (203.01 KB, image/png)
2018-08-02 14:05 UTC, Nikhil Kathole
no flags Details
screenshot of UI history of content views (140.86 KB, image/png)
2018-08-02 14:06 UTC, Nikhil Kathole
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 23667 0 None None None 2018-05-22 12:33:57 UTC
Red Hat Product Errata RHBA-2018:2550 0 None None None 2018-08-22 20:07:47 UTC

Description Julio Entrena Perez 2018-05-08 13:55:01 UTC
Description of problem:
After upgrading from Satellite 6.2(.14) to 6.3(.1) the promotion history of content views doesn't display correct information.

Version-Release number of selected component (if applicable):
satellite-6.3.1-3.el7sat

How reproducible:
Unknown.

Steps to Reproduce:
1. Upgrade to Satellite 6.3(.1).
2.
3.

Actual results:
- https://<satellite>/content_views/<cv_id>/history
  - has wrong timestamps for "Date" column (it shows the time of the upgrade to 6.3 for all entries in the table rather than the individual timestamp for each action).
  - is missing the values for "Action" column (it shows "{{ actionText(history) }}" instead of the actual action.

- https://<satellite>/content_views/<cv_id>/versions
  - same issues.

Expected results:
The timestamps and actions are preserved through the upgrade and are still available after the upgrade.

Additional info:
The list of CVs https://<satellite>/content_views does show the correct timestamp for the latest action for each CV.

Comment 4 Andrew Kofink 2018-05-22 12:33:55 UTC
Created redmine issue http://projects.theforeman.org/issues/23667 from this bug

Comment 5 Brad Buckingham 2018-06-12 13:25:40 UTC
Moving to POST, since upstream PR is merged.

Comment 7 Nikhil Kathole 2018-08-02 14:04:06 UTC
VERIFIED

Version tested:

# rpm -q satellite
satellite-6.3.3-1.el7sat.noarch

Upgraded from satellite 6.2.15 to 6.3.3 snap 2, The timestamp and history of content views found intact after upgrade.(see attachment)

Comment 8 Nikhil Kathole 2018-08-02 14:05:10 UTC
Created attachment 1472712 [details]
screenshot of UI timestamp intact after upgrade

Comment 9 Nikhil Kathole 2018-08-02 14:06:18 UTC
Created attachment 1472714 [details]
screenshot of UI history of content views

Comment 11 errata-xmlrpc 2018-08-22 20:07:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2550


Note You need to log in before you can comment on or make changes to this bug.