Bug 1576003 - ntp package is missing from undercloud
Summary: ntp package is missing from undercloud
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Emilien Macchi
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 14:12 UTC by Noam Manos
Modified: 2018-06-27 13:56 UTC (History)
8 users (show)

Fixed In Version: instack-undercloud-8.4.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:55:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 563299 None MERGED Always deploy NTP 2020-05-01 20:18:27 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:56:49 UTC

Description Noam Manos 2018-05-08 14:12:03 UTC
Description of problem:
Updating Undercloud with latest packages as described here:
https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/12/html/upgrading_red_hat_openstack_platform/keeping_openstack_platform_updated

Requires to check that clocks are synchronized on the undercloud with ntpstat.
However it fails with "ntpstat: command not found".


Version-Release number of selected component (if applicable):
OSP: 13   
Puddle: 2018-04-10.2

How reproducible:
Always


Steps to Reproduce:
(undercloud) [stack@undercloud-0 ~]$ sudo ntpstat


Actual results:
sudo: ntpstat: command not found


Expected results:

ntpstat should work.
Or, if it is not necessary, remove ntpstat step from:
https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/12/html/upgrading_red_hat_openstack_platform/keeping_openstack_platform_updated

Comment 1 Noam Manos 2018-05-08 14:43:35 UTC
Workaround:

(undercloud) [stack@undercloud-0 ~]$ sudo yum install ntp
...                                                                                                                                                                                      
Installed:
  ntp.x86_64 0:4.2.6p5-28.el7                                                                                                                                                                                                                  
                                                                                                                                                                                                          

(undercloud) [stack@undercloud-0 ~]$ sudo systemctl enable ntpd

Created symlink from /etc/systemd/system/multi-user.target.wants/ntpd.service to /usr/lib/systemd/system/ntpd.service.

(undercloud) [stack@undercloud-0 ~]$ sudo systemctl start ntpd

(undercloud) [stack@undercloud-0 ~]$ sudo ntpstat

unsynchronised
  time server re-starting
   polling server every 8 s

(undercloud) [stack@undercloud-0 ~]$ sudo ntpstat

synchronised to NTP server (138.236.128.112) at stratum 3 
   time correct to within 1110 ms
   polling server every 64 s

Comment 2 Alex Schultz 2018-05-08 16:25:49 UTC
It is not installed unless you configure ntp via the undercloud.conf. We've recently changed this to always be installed, but if you aren't properly configuring the ntp servers in the undercloud.conf at install time it would not install ntp.

Comment 6 errata-xmlrpc 2018-06-27 13:55:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.