Bug 1576017 - [RFE][upstream][v2v] Infrastructure mapping - unable to map target DS with size lower than source DS
Summary: [RFE][upstream][v2v] Infrastructure mapping - unable to map target DS with si...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Aparna Karve
QA Contact: Kedar Kulkarni
URL:
Whiteboard: v2v
: 1614470 (view as bug list)
Depends On:
Blocks: 1564236 1595446
TreeView+ depends on / blocked
 
Reported: 2018-05-08 14:51 UTC by Mor
Modified: 2019-02-11 14:05 UTC (History)
13 users (show)

Fixed In Version: 5.10.0.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1595446 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:05:59 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)
screenshot (55.27 KB, image/png)
2018-05-08 14:51 UTC, Mor
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/ManageIQ miq_v2v_ui_plugin issues 345 0 None None None 2018-05-24 04:01:04 UTC

Description Mor 2018-05-08 14:51:29 UTC
Created attachment 1433255 [details]
screenshot

Description of problem:
When trying to map a target datastore with size lower than the source datastore, MIQ blocks the mapping with error: "The size of the selected source datastores exceeds the available space in the target datastore". 

This check should be added to the migration job itself, and needs to be calculated per selected VM's total size.

Version-Release number of selected component (if applicable):
MIQ master.20180504232106_a937a31 

How reproducible:
100%

Steps to Reproduce:
1. Try to map target DS to bigger source DS in size.

Actual results:
Error and mapping is blocked.

Expected results:
Should not block the mapping.

Additional info:

Comment 2 Mor 2018-05-17 09:16:54 UTC
Changing the severity to high. 
Adding a testblocker since it blocks nsimsolo from running a test with his VMWare and RHV environments.

Comment 3 Brett Thurber 2018-05-24 04:01:04 UTC
Verified this still exists .  Upstream issue here:  https://github.com/ManageIQ/miq_v2v_ui_plugin/issues/345

Comment 4 Mor 2018-06-10 09:05:48 UTC
This is currently blocking us from testing the environment. Our target DS got filled and we reinstalled MIQ, thus mapping cannot be done now.

Comment 5 Brett Thurber 2018-06-11 03:27:17 UTC
(In reply to Mor from comment #4)
> This is currently blocking us from testing the environment. Our target DS
> got filled and we reinstalled MIQ, thus mapping cannot be done now.

As a workaround can you clean up your target datastore to resume testing?

Comment 6 Mor 2018-06-11 05:23:00 UTC
At the end, we ended up creating a new DS for the process and resumed testing. So I'm switching back to HIGH.

Comment 16 Mor 2018-07-03 09:00:29 UTC
Can I verify this but currently? Is 5.9.4.x available for V2V testing? We currently run on 5.9.3.x.

Comment 17 Mor 2018-07-03 09:35:55 UTC
* correction: I can verify this, but currently is 5.9.4x available for V2V testing? We currently run on 5.9.3.x.

Comment 25 Kedar Kulkarni 2018-07-05 19:02:16 UTC
On 5.10.0.2 I observed that there is no more Validations on Datastore sizes. User is free to choose any source/target datastores, no size checking/restrictions.

Comment 26 Daniel Gur 2018-07-17 20:57:21 UTC
Verified by CFME functional QE.

Comment 27 Satoe Imaishi 2018-08-09 21:29:21 UTC
*** Bug 1614470 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.