Bug 1576039 - Fedora on Pine 64 LTS issues
Summary: Fedora on Pine 64 LTS issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: uboot-tools
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 16:07 UTC by Mohan Boddu
Modified: 2018-09-11 12:44 UTC (History)
4 users (show)

Fixed In Version: uboot-tools-2018.09-0.4.rc3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-11 12:44:29 UTC
Type: Bug


Attachments (Terms of Use)
The output of all the commands that I ran in uboot. (12.00 KB, text/plain)
2018-05-08 16:07 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-05-08 16:07:33 UTC
Created attachment 1433292 [details]
The output of all the commands that I ran in uboot.

Description of problem:
Two problems:
1. Uboot not picking the right dtb file
2. Its not able to save the env after giving the right dtb file

How reproducible:
Everytime

Steps to Reproduce:
1. fedora-arm-image-installer --image=Fedora-Minimal-28-1.1.aarch64.raw.xz --target=sopine_baseboard --media=/dev/mmcblk0
And then under uboot:
2. env print | grep fdtfile
fdtfile=allwinner/sun50i-a64-pine64-plus.dtb
3. setenv fdtfile allwinner/sun50i-a64-sopine-baseboard.dtb
4. env print | grep fdtfile
fdtfile=allwinner/sun50i-a64-sopine-baseboard.dtb
5. => saveenv
Saving Environment to FAT... Card did not respond to voltage select!
** Bad device mmc 1 **
Failed (1)
Saving Environment to MMC... Card did not respond to voltage select!
!MMC init failed
Failed (1)
6. => mmc list
SUNXI SD/MMC: 0 (SD)
SUNXI SD/MMC: 1

=> mmc dev 0
switch to partitions #0, OK
mmc0 is current device

=> mmc dev
switch to partitions #0, OK
mmc0 is current device

Since I am not able to save the env, whenever it reboots, I have to set it again in uboot which is a headache.

Comment 1 Jan Kurik 2018-08-14 10:03:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Fedora Update System 2018-09-05 22:09:11 UTC
arm-trusted-firmware-1.5-4.20180830.fc29 bcm283x-firmware-20180829-3.ec3f856.fc29 uboot-tools-2018.09-0.4.rc3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-56bc88dfb2

Comment 3 Fedora Update System 2018-09-07 06:00:01 UTC
arm-trusted-firmware-1.5-4.20180830.fc29, bcm283x-firmware-20180829-3.ec3f856.fc29, uboot-tools-2018.09-0.4.rc3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-56bc88dfb2

Comment 4 Fedora Update System 2018-09-11 12:44:29 UTC
arm-trusted-firmware-1.5-4.20180830.fc29, bcm283x-firmware-20180829-3.ec3f856.fc29, uboot-tools-2018.09-0.4.rc3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.