Bug 1576052 - [RFE] Encrypt password in ~/.hammer/cli.modules.d/foreman.yml
Summary: [RFE] Encrypt password in ~/.hammer/cli.modules.d/foreman.yml
Keywords:
Status: CLOSED DUPLICATE of bug 230204
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Suraj Bora
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 16:22 UTC by Skip Wyatt
Modified: 2019-03-29 06:34 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-06 18:22:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3566021 0 None None None 2018-08-24 12:19:19 UTC

Description Skip Wyatt 2018-05-08 16:22:32 UTC
Description of problem:

Customer performs automation using hammer and cannot have non-encrypted passwords at rest in ~/.hammer/cli.modules.d/foreman.yml

Because these are automated jobs, they do not have user interaction for foreman auth

Version-Release number of selected component (if applicable):

Satellite 6.3.1

How reproducible:

Everytime

Expected results:
Customer wants an option like virt-who-password, which encrypts the password and performs a lookup based upon the hash for the user.

Comment 1 Skip Wyatt 2018-05-08 16:24:05 UTC
> Because these are automated jobs, they do not have user interaction for foreman auth

This should read hammer auth

Comment 4 Marek Hulan 2018-09-14 08:24:17 UTC
Isn't the file owned by root already? the key benefit for virt-who-password is that only root can use it and the master password is still stored on harddrive in plaintext, just in other file accessible by root only. IMHO there's no point in adding this to hammer. Hammer now supports sessions and x509 certs (6.4 for x509 IIRC) so if people don't want to store password, they don't have to.

Also the very same request was closed in BZ 230204 as won't fix. I'd suggest closing this as a duplicate of the very same BZ.

Comment 5 Bryan Kearney 2018-12-06 18:22:48 UTC
As Marek mentioned, this has already been closed. Since we need the password in clear text we would need to symmetricly encrypt this password with another password that will need to be in clear text. Closing this out.

*** This bug has been marked as a duplicate of bug 230204 ***


Note You need to log in before you can comment on or make changes to this bug.