Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1576128 - The configured theme "02-fedora" doesn't exist, using the embedded theme instead
Summary: The configured theme "02-fedora" doesn't exist, using the embedded theme instead
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sddm
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 22:29 UTC by Germano Massullo
Modified: 2018-05-26 20:41 UTC (History)
6 users (show)

Fixed In Version: sddm-0.17.0-3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-26 20:41:10 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of "wrong / bad" sddm screen (66.30 KB, image/jpeg)
2018-05-20 12:34 UTC, Germano Massullo
no flags Details
screenshot of "good" sddm screen (89.07 KB, image/jpeg)
2018-05-20 12:35 UTC, Germano Massullo
no flags Details
screenshot of "keyboard" sddm screen (43.68 KB, image/jpeg)
2018-05-20 12:35 UTC, Germano Massullo
no flags Details
sddm.conf (173 bytes, text/plain)
2018-05-20 12:35 UTC, Germano Massullo
no flags Details
sddm.conf.rpmnew (2.63 KB, text/plain)
2018-05-20 12:36 UTC, Germano Massullo
no flags Details
sddm.conf.rpmsave (170 bytes, text/plain)
2018-05-20 12:36 UTC, Germano Massullo
no flags Details

Description Germano Massullo 2018-05-08 22:29:26 UTC
Description of problem:
There is something wrong in F27->F28 upgrade. On two different machines I got the same problem: sddm starts with a very basic theme, and after ~2 seconds a virtual keyboard appears

Expected results:
Having sddm with regular F28 theme

Version-Release number of selected component (if applicable):
sddm-0.17.0-2.fc28.x86_64


Additional info:
OS is Fedora KDE Spin


# journalctl -u sddm --since today --no-pager
-- Logs begin at Wed 2016-07-27 23:42:50 CEST, end at Tue 2018-05-08 23:50:06 CEST. --
mag 08 17:12:03 T420 systemd[1]: Started Simple Desktop Display Manager.
mag 08 17:12:17 T420 sddm-helper[891]: PAM unable to dlopen(/usr/lib64/security/pam_elogind.so): /usr/lib64/security/pam_elogind.so: cannot open shared object file: No such file or directory
mag 08 17:12:17 T420 sddm-helper[891]: PAM adding faulty module: /usr/lib64/security/pam_elogind.so
mag 08 17:12:18 T420 sddm-helper[891]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
mag 08 17:12:34 T420 sddm-helper[927]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
mag 08 17:12:35 T420 sddm-helper[927]: pam_kwallet(sddm:auth): (null): pam_sm_authenticate
mag 08 17:12:35 T420 sddm-helper[927]: pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
mag 08 17:12:35 T420 sddm-helper[927]: pam_kwallet(sddm:setcred): pam_kwallet: pam_sm_setcred
mag 08 17:14:05 T420 sddm[822]: kwalletd5: Checking for pam module
mag 08 17:14:05 T420 sddm[822]: kwalletd5: Got pam-login param
mag 08 17:14:05 T420 sddm[822]: kwalletd5: Waiting for hash on 14-
mag 08 17:14:05 T420 sddm[822]: kwalletd5: waitingForEnvironment on: 17
mag 08 17:14:05 T420 sddm[822]: kwalletd5: client connected
mag 08 17:14:05 T420 sddm[822]: kwalletd5: client disconnected
mag 08 18:57:06 T420 sddm[822]: Checking for pam module
mag 08 18:57:06 T420 sddm[822]: Got pam-login
mag 08 18:57:06 T420 sddm[822]: kwalletd: Waiting for hash on 14-
mag 08 18:57:06 T420 sddm[822]: kwalletd: waitingForEnvironment on: 18
mag 08 18:57:06 T420 sddm[822]: kwalletd: client connected
mag 08 18:57:06 T420 sddm[822]: kwalletd: client disconnected
mag 08 18:57:15 T420 sddm-helper[25219]: PAM unable to dlopen(/usr/lib64/security/pam_elogind.so): /usr/lib64/security/pam_elogind.so: cannot open shared object file: No such file or directory
mag 08 18:57:15 T420 sddm-helper[25219]: PAM adding faulty module: /usr/lib64/security/pam_elogind.so
mag 08 18:57:15 T420 sddm-helper[25219]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
mag 08 18:57:32 T420 sddm[822]: Error from greeter session: "Process crashed"
mag 08 18:57:32 T420 sddm[822]: Auth: sddm-helper crashed (exit code 15)
mag 08 18:57:32 T420 sddm[822]: Error from greeter session: "Process crashed"
mag 08 18:57:32 T420 sddm[822]: Auth: sddm-helper exited with 15
mag 08 18:57:32 T420 systemd[1]: Stopping Simple Desktop Display Manager...
mag 08 18:57:32 T420 sddm[822]: Signal received: SIGTERM
mag 08 18:57:32 T420 systemd[1]: Stopped Simple Desktop Display Manager.
-- Reboot --
mag 08 21:13:56 T420 systemd[1]: Started Simple Desktop Display Manager.
mag 08 21:14:12 T420 sddm[950]: The configured theme "02-fedora" doesn't exist, using the embedded theme instead
mag 08 21:14:12 T420 sddm-helper[1059]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
mag 08 23:20:13 T420 sddm-helper[1464]: pam_unix(sddm:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=  user=achille
mag 08 23:20:13 T420 sddm-helper[1464]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
mag 08 23:20:14 T420 sddm-helper[1464]: [PAM] authenticate: Authentication failure
mag 08 23:20:14 T420 sddm[950]: Authentication error: "Authentication failure"
mag 08 23:20:14 T420 sddm[950]: Auth: sddm-helper exited with 1
mag 08 23:29:21 T420 sddm[950]: Signal received: SIGTERM
mag 08 23:29:21 T420 systemd[1]: Stopping Simple Desktop Display Manager...
mag 08 23:29:21 T420 sddm[950]: QProcess: Destroyed while process ("/usr/libexec/sddm-helper") is still running.
mag 08 23:29:21 T420 systemd[1]: Stopped Simple Desktop Display Manager.
mag 08 23:29:21 T420 systemd[1]: Started Simple Desktop Display Manager.
mag 08 23:29:22 T420 sddm[1557]: The configured theme "02-fedora" doesn't exist, using the embedded theme instead
mag 08 23:29:22 T420 sddm-helper[1567]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
mag 08 23:29:31 T420 sddm-helper[1583]: pam_unix(sddm:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=  user=achille
mag 08 23:29:31 T420 sddm-helper[1583]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
mag 08 23:29:33 T420 sddm-helper[1583]: [PAM] authenticate: Authentication failure
mag 08 23:29:33 T420 sddm[1557]: Authentication error: "Authentication failure"
mag 08 23:29:33 T420 sddm[1557]: Auth: sddm-helper exited with 1
mag 08 23:30:37 T420 sddm[1557]: Signal received: SIGTERM
mag 08 23:30:37 T420 systemd[1]: Stopping Simple Desktop Display Manager...
mag 08 23:30:37 T420 sddm[1557]: QProcess: Destroyed while process ("/usr/libexec/sddm-helper") is still running.
mag 08 23:30:37 T420 systemd[1]: Stopped Simple Desktop Display Manager.
-- Reboot --
mag 08 23:31:43 T420 systemd[1]: Started Simple Desktop Display Manager.
mag 08 23:31:53 T420 sddm[887]: The configured theme "02-fedora" doesn't exist, using the embedded theme instead
mag 08 23:31:54 T420 sddm-helper[974]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
mag 08 23:32:57 T420 sddm-helper[1164]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
mag 08 23:32:57 T420 sddm-helper[1164]: pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
mag 08 23:32:57 T420 sddm[887]: Authentication information: "Last failed login: Tue May  8 23:29:33 CEST 2018"
mag 08 23:32:58 T420 sddm[887]: Authentication information: "There were 2 failed login attempts since the last successful login."
mag 08 23:33:35 T420 sddm[887]: kwalletd5: Checking for pam module
mag 08 23:33:35 T420 sddm[887]: kwalletd5: Got pam-login param
mag 08 23:33:35 T420 sddm[887]: kwalletd5: Waiting for hash on 14-
mag 08 23:33:35 T420 sddm[887]: kwalletd5: waitingForEnvironment on: 17
mag 08 23:33:35 T420 sddm[887]: kwalletd5: client connected
mag 08 23:33:35 T420 sddm[887]: kwalletd5: client disconnected
mag 08 23:44:19 T420 sddm[887]: Authentication error: "Process crashed"
mag 08 23:44:19 T420 sddm[887]: Auth: sddm-helper crashed (exit code 15)
mag 08 23:44:19 T420 sddm[887]: Authentication error: "Process crashed"
mag 08 23:44:19 T420 sddm[887]: Auth: sddm-helper exited with 15
mag 08 23:44:19 T420 systemd[1]: Stopping Simple Desktop Display Manager...
mag 08 23:44:20 T420 sddm[887]: The configured theme "02-fedora" doesn't exist, using the embedded theme instead
mag 08 23:44:20 T420 sddm[887]: Signal received: SIGTERM
mag 08 23:44:20 T420 sddm[887]: QProcess: Destroyed while process ("/usr/libexec/sddm-helper") is still running.
mag 08 23:44:20 T420 systemd[1]: Stopped Simple Desktop Display Manager.
-- Reboot --
mag 08 23:45:25 T420 systemd[1]: Started Simple Desktop Display Manager.
mag 08 23:45:38 T420 sddm[807]: Could not setup default cursor
mag 08 23:45:38 T420 sddm[807]: The configured theme "02-fedora" doesn't exist, using the embedded theme instead
mag 08 23:45:40 T420 sddm-helper[909]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
mag 08 23:46:02 T420 sddm-helper[1007]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
mag 08 23:46:03 T420 sddm[807]: Authentication information: "Last failed login: Tue May  8 23:29:33 CEST 2018"
mag 08 23:46:06 T420 sddm[807]: Authentication information: "There were 2 failed login attempts since the last successful login."
mag 08 23:46:28 T420 sddm[807]: kwalletd5: Checking for pam module
mag 08 23:46:28 T420 sddm[807]: kwalletd5: Got pam-login param
mag 08 23:46:28 T420 sddm[807]: kwalletd5: Waiting for hash on 14-
mag 08 23:46:28 T420 sddm[807]: kwalletd5: waitingForEnvironment on: 17
mag 08 23:46:28 T420 sddm[807]: kwalletd5: client connected
mag 08 23:46:28 T420 sddm[807]: kwalletd5: client disconnected

Comment 1 Rex Dieter 2018-05-09 13:47:10 UTC
The custom 02-fedora theme was indeed removed in favor of better-maintained built-in themes.

that said, the built-in themes do not seem to handle the onscreen/virtual keyboard feature very well:
* it shouldn't display initially/by-default
* discoverability isn't great (initial clicks on whitespace will trigger it)

Due to this, I'll remove the
Recommends: qt5-qtvirtualkeyboard
from sddm (downgrade to Suggests, which are dependencies not installed by default).

In the meantime, workarounds include:
* when onscreen keyboard is displayed, click lower/right keyboard icon to hide it
* remove/uninstall qt5-qtvirtualkeyboard package to disable the feature

Comment 2 Rex Dieter 2018-05-09 13:49:16 UTC
Another alternative workaround: use the 01-breeze-fedora sddm theme, which is the default on kde spin (it handles the virtualkeyboard feature better)

Comment 3 Fedora Update System 2018-05-14 17:01:00 UTC
sddm-0.17.0-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-137a0296be

Comment 4 Fedora Update System 2018-05-15 23:02:30 UTC
sddm-0.17.0-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-137a0296be

Comment 5 Germano Massullo 2018-05-20 12:34:34 UTC
Created attachment 1439154 [details]
screenshot of "wrong / bad" sddm screen

Comment 6 Germano Massullo 2018-05-20 12:35:09 UTC
Created attachment 1439155 [details]
screenshot of "good" sddm screen

Comment 7 Germano Massullo 2018-05-20 12:35:35 UTC
Created attachment 1439156 [details]
screenshot of "keyboard" sddm screen

Comment 8 Germano Massullo 2018-05-20 12:35:58 UTC
Created attachment 1439157 [details]
sddm.conf

Comment 9 Germano Massullo 2018-05-20 12:36:30 UTC
Created attachment 1439158 [details]
sddm.conf.rpmnew

Comment 10 Germano Massullo 2018-05-20 12:36:50 UTC
Created attachment 1439159 [details]
sddm.conf.rpmsave

Comment 11 Germano Massullo 2018-05-20 12:44:08 UTC
I added screenshots for information completeness because I am sure other users may encounter this problem.
I installed the sddm-0.17.0-3.fc28 update, which changed anything.
By looking for sddm conf file into /etc, I found out files

sddm.conf
sddm.conf.rpmnew
sddm.conf.rpmsave

I solved the problem by replacing sddm.conf with sddm.conf.rpmnew

Note: despite sddm.conf said
[Theme]
Current=02-fedora

in Plasma system settings, the selected SDDM theme was (if I recall correctly) Breeze Fedora, like in systems not affected by the problem.
Indeed, in F27, I don't remember the affected machine having a different SDDM theme compared to my other machines.
At home I had also another machine with the same problem, but I cannot check the sddm.conf file since the hard drive started failing.
Perhaps the 02-fedora removal should have planned/triggered a cleaning in conf files that used it?

Comment 12 Rex Dieter 2018-05-20 21:44:49 UTC
Your "bad" screen is clearly using the default (built-in) sddm theme, which is expected based on the sddm.conf attached here (not a bug).  The "good" one is clearly configured to use breeze theme.

Re: comment #11
Can't go modifying sddm.conf in a scriptlet without it being marked as modified (and subsequent sddm upgrades will no longer replace it, similar to the problem outlined here which started with a customized sddm.conf + the use of:
%config(noreplace) .../sddm.conf

To reiterate:
The sddm update in question
https://bodhi.fedoraproject.org/updates/FEDORA-2018-137a0296be

removed the dependency on qt5-qtvirtualkeyboard so that it will no longer get installed by default via dependencies from sddm

So, you can remove it to avoid the problem of it displaying by default.

Comment 13 Fedora Update System 2018-05-26 20:41:10 UTC
sddm-0.17.0-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.