Bug 1576149 - [gnome-screensaver-2.28.3-28.el6] lock screen malfunction for root user on RHEL6.10 beta
Summary: [gnome-screensaver-2.28.3-28.el6] lock screen malfunction for root user on RH...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-screensaver
Version: 6.10
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 01:19 UTC by frank
Modified: 2018-05-10 15:02 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 15:02:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description frank 2018-05-09 01:19:12 UTC
Description of problem:
gnome-screensaver-2.28.3-28.el6] lock screen malfunction for root user on RHEL6.10 beta.
Version-Release number of selected component (if applicable):
gnome-screensaver-2.28.3-28.el6.x86_64
(RHEL6.10 kernel: 2.6.32-749.el6.x86_64)

How reproducible:

Steps to Reproduce:
1.Install RHEL 6.10 Beta(Kernel:2.6.32-749.el6.x86_64) and login OS with root account.
2.Try to lock screen for root user by click "Lock Screen" from system status area(Top-right), but Lock Screen is malfunction for root user.
3.Launch "DISPLAY=:0 gnome-screensaver-command -l" on command shell is the same to duplicate issue

Actual results:
Lock screen malfunction

Expected results:
Lock screen works for root user.

Additional info:

Comment 2 Ray Strode [halfline] 2018-05-10 15:02:11 UTC
That's actually by design.  gnome-screensaver doesn't allow the screen to be locked for the root user.


Note You need to log in before you can comment on or make changes to this bug.