Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1576247 - Cannot install vim-enhanced
Summary: Cannot install vim-enhanced
Keywords:
Status: CLOSED DUPLICATE of bug 1575354
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 07:04 UTC by Guus Leeuw jr.
Modified: 2018-05-09 08:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 08:44:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Guus Leeuw jr. 2018-05-09 07:04:24 UTC
Description of problem:
I have a standard alias:
alias vi=vim

When I start vi, I get the following output:
[leeuwg@localhost feature_branch]$ vi
bash: vim: command not found...
Install package 'vim-enhanced' to provide command 'vim'? [N/y] y


 * Waiting in queue... Failed to install packages: Could not depsolve transaction; 1 problem detected:
0. nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64



Version-Release number of selected component (if applicable):
8.0.1788-1.fc28.x86_64

How reproducible:
Have a konsole open with the given alias, and start `vi`


Steps to Reproduce:
1. Open a Konsole
2. Make sure the vi alias is set to vim
3. Start vi
4. Say `y` if the system asks you to install vim-enhanced

Actual results:
 * Waiting in queue... Failed to install packages: Could not depsolve transaction; 1 problem detected:
0. nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64


Expected results:
vim-enhanced successfully installed

Additional info:

Comment 1 Michal Špondr 2018-05-09 07:35:49 UTC
Same here. I can not upgrade packages successfully:

$ sudo dnf update
Last metadata expiration check: 0:21:13 ago on Wed 09 May 2018 09:11:46 AM CEST.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package vim-enhanced-2:8.0.1704-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64
 Problem 2: problem with installed package vim-enhanced-2:8.0.1704-1.fc28.x86_64
  - package vim-enhanced-2:8.0.1704-1.fc28.x86_64 requires vim-common = 2:8.0.1704-1.fc28, but none of the providers can be installed
  - cannot install both vim-common-2:8.0.1788-1.fc28.x86_64 and vim-common-2:8.0.1704-1.fc28.x86_64
  - cannot install both vim-common-2:8.0.1704-1.fc28.x86_64 and vim-common-2:8.0.1788-1.fc28.x86_64
  - cannot install the best update candidate for package vim-common-2:8.0.1704-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64
=====================================================================================================================================================
 Package                              Arch                           Version                                   Repository                       Size
=====================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 vim-common                           x86_64                         2:8.0.1788-1.fc28                         updates                         6.4 M
Skipping packages with broken dependencies:
 vim-enhanced                         x86_64                         2:8.0.1788-1.fc28                         updates                         1.3 M

Transaction Summary
=====================================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!

Comment 2 Zdenek Dohnal 2018-05-09 08:44:48 UTC

*** This bug has been marked as a duplicate of bug 1575354 ***


Note You need to log in before you can comment on or make changes to this bug.