Bug 1576310 - [OVN] - [HE] - ovn tunnel is not created if central hostname resolved as 127.0.0.1 in hosts file
Summary: [OVN] - [HE] - ovn tunnel is not created if central hostname resolved as 127....
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network
Version: 2.2.19
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-4.2.4
: 2.2.22
Assignee: Simone Tiraboschi
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks: ovirt-hosted-engine-setup-2.2.22
TreeView+ depends on / blocked
 
Reported: 2018-05-09 08:20 UTC by Michael Burman
Modified: 2018-06-26 08:42 UTC (History)
5 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.22
Doc Type: Bug Fix
Doc Text:
OVN central is installed on the hosted-engine VM; the hosts should point to it using its IP address which is available just at the end of the setup so the setup will temporary use the bootstrap address at setup time fixing it with the target address just at the end.
Clone Of:
Environment:
Last Closed: 2018-06-26 08:42:00 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91275 0 master MERGED Remove engine FQDN temporary tweak at the end 2020-06-25 15:14:59 UTC
oVirt gerrit 91372 0 master MERGED network: reconfigure OVN central 2020-06-25 15:14:59 UTC
oVirt gerrit 91797 0 ovirt-hosted-engine-setup-2.2 MERGED Remove engine FQDN temporary tweak at the end 2020-06-25 15:14:59 UTC
oVirt gerrit 91798 0 ovirt-hosted-engine-setup-2.2 MERGED network: reconfigure OVN central 2020-06-25 15:14:59 UTC

Description Michael Burman 2018-05-09 08:20:50 UTC
Description of problem:
[OVN] - [HE] - ovn tunnel doesn't created if central hostname resolved as 127.0.0.1 in hosts file 

When running hosted engine deploy, user is asked if he want to add the VM's FQDN to /etc/hosts file and resolved as 127.0.01, if choosing 'yes' then the ovn deploy using 127.0.0.1 as central and then no ovn tunnel is created on the host/s.

 2018-05-09 10:05:42,563 p=61921 u=ovirt | TASK [ovirt-provider-ovn-driver : Configure OVN for oVirt] ********************* 2018-05-09 10:05:50,118 p=61921 u=ovirt | changed: [lynx03.lab.eng.tlv2.redhat.com] => { "changed": true, "cmd": [ "vdsm-tool", "ovn-config", "127.0.0.1", "10.46.16.22" ], "delta": "0:00:06.741161", "end": "2018-05-09 10:05:50.029649", "rc": 0, "start":
"2018-05-09 10:05:43.288488" }


Version-Release number of selected component (if applicable):
4.2.3.5-0.1.el7


How reproducible:
100% 

Steps to Reproduce:
1. Run hosted-engine deploy and choose yes to add the VM's FQDN to hosts file

Actual results:
Try to use ovn in this engine after deploy is done
NO tunnel created on the host/s

Expected results:
We should handle such use case for users that choose to add their FQDNs to hosts file and resolved as 127.0.01

Comment 1 Michael Burman 2018-06-06 14:09:43 UTC
Verified on - ovirt-hosted-engine-setup-2.2.22-1.el7ev.noarch

Comment 2 Sandro Bonazzola 2018-06-26 08:42:00 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.