Bug 1576312 - The error info is not accurate when creating image just specifying size but not image file name
Summary: The error info is not accurate when creating image just specifying size but n...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Max Reitz
QA Contact: Tingting Mao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 08:25 UTC by Tingting Mao
Modified: 2018-12-21 23:07 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-21 23:07:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tingting Mao 2018-05-09 08:25:11 UTC
Description of problem:
The error info is not accurate when creating image just specifying size but not image file name

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.12.0-1.el7

How reproducible:
100%

Steps to Reproduce:
# qemu-img create -f qcow2 10G
qemu-img: 10G: Image creation needs a size parameter


Actual results:


Expected results:
The error info should be like as below:
qemu-img: Image creation needs a image file name
Try 'qemu-img --help' for more information

Additional info:

Comment 3 Ademar Reis 2018-12-21 23:07:16 UTC
(In reply to Tingting Mao from comment #0)
> Description of problem:
> The error info is not accurate when creating image just specifying size but
> not image file name
> 
> Version-Release number of selected component (if applicable):
> qemu-kvm-rhev-2.12.0-1.el7
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> # qemu-img create -f qcow2 10G
> qemu-img: 10G: Image creation needs a size parameter
> 

In the command line above, there's nothing to indicate to qemu-img that 10G is the size. As far as it knows, "10G" is the name of the image and you're not providing the size.

I understand this might be confusing, but I'm closing this one because we need to focus on high priority issues.


Note You need to log in before you can comment on or make changes to this bug.