Bug 1576343 - [mixed versions] scale out failed: ERROR pulling 192.168.24.1:8787/rhceph:2.5-3 image docker isn't running on compute node
Summary: [mixed versions] scale out failed: ERROR pulling 192.168.24.1:8787/rhceph:2.5...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 13.0 (Queens)
Assignee: Alex Schultz
QA Contact: Artem Hrechanychenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 08:51 UTC by Ronnie Rasouli
Modified: 2018-06-27 13:56 UTC (History)
15 users (show)

Fixed In Version: openstack-tripleo-common-8.6.1-15
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:55:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:56:36 UTC

Description Ronnie Rasouli 2018-05-09 08:51:00 UTC
Description of problem:

While performing scale out for stage upgrade, the scale out stage failed with error:

cat openstack_failures_scale_up.log
overcloud.AllNodesDeploySteps.WorkflowTasks_Step2_Execution:
  resource_type: OS::Mistral::ExternalResource
  physical_resource_id: 9774293d-fcdb-40b6-99d2-463cc49ad38b
  status: CREATE_FAILED
  status_reason: |
    resources.WorkflowTasks_Step2_Execution: ERROR

The newly compute node has been created, however the docker isn't running on that node.

looking at the /var/log/mistral/ceph-install-workflow.log

ERROR pulling 192.168.24.1:8787/rhceph:2.5-3


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ronnie Rasouli 2018-05-09 08:53:14 UTC
versions:
openstack-mistral-common-6.0.2-1.el7ost.noarch
instack-undercloud-8.4.1-4.el7ost.noarch
puppet-ceph-2.5.0-1.el7ost.noarch

Comment 2 Ronnie Rasouli 2018-05-09 09:38:36 UTC
The reports should be available here: http://rhos-release.virt.bos.redhat.com/log/bz1576343

Comment 25 Jon Schlueter 2018-05-23 15:36:57 UTC
Is a valid workaround for this issue to make sure to include docker.yaml and docker-ha.yaml env files when you make scale out calls?

Comment 26 Alex Schultz 2018-05-23 16:18:25 UTC
Yes in order to ensure it works after an upgrade the following should be used after installing openstack-tripleo-heat-templates-compat.

The deployment command used to manage an OSP12 must include, -e /usr/share/openstack-tripleo-heat-templates/compat/environments/docker.yaml and -e /usr/share/openstack-tripleo-heat-templates/compat/environments/docker-ha.yaml.

Comment 35 errata-xmlrpc 2018-06-27 13:55:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.