Bug 1576363 - glibc: Use annobin annotations for assembler code
Summary: glibc: Use annobin annotations for assembler code
Keywords:
Status: CLOSED DUPLICATE of bug 1668822
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1576362
Blocks: 1576372
TreeView+ depends on / blocked
 
Reported: 2018-05-09 09:35 UTC by Florian Weimer
Modified: 2019-10-15 13:27 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1576372 (view as bug list)
Environment:
Last Closed: 2019-10-15 13:27:23 UTC
Type: Bug


Attachments (Terms of Use)
Use ASFLAGS to pass assembler flags (1.44 KB, patch)
2018-05-09 09:37 UTC, Florian Weimer
no flags Details | Diff

Description Florian Weimer 2018-05-09 09:35:41 UTC
If the DWARF coverage is not sufficient, we need to annotate the assembler-generated object files (such as the string functions).  We currently cannot do this due to bug 1576362.

Comment 1 Florian Weimer 2018-05-09 09:37:11 UTC
Created attachment 1433704 [details]
Use ASFLAGS to pass assembler flags

Using ASFLAGS is a bit tricky, so here's a patch to do it.

Comment 2 Jan Kurik 2018-08-14 10:03:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 3 Florian Weimer 2019-10-15 13:27:23 UTC

*** This bug has been marked as a duplicate of bug 1668822 ***


Note You need to log in before you can comment on or make changes to this bug.