Bug 1576391 - Paths in config should not include trailing /
Summary: Paths in config should not include trailing /
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic
Version: 1.1.4.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-4.2.5
: 1.1.6
Assignee: Shirly Radco
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks: ovirt-engine-metrics-1.1.6
TreeView+ depends on / blocked
 
Reported: 2018-05-09 11:04 UTC by Lukas Svaty
Modified: 2018-07-31 15:31 UTC (History)
1 user (show)

Fixed In Version: ovirt-engine-metrics-1.1.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 15:31:36 UTC
oVirt Team: Metrics
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 92487 0 ovirt-engine-metrics-4.2 MERGED Remove trailing / from paths in config 2018-06-25 11:54:12 UTC
oVirt gerrit 92489 0 ovirt-engine-metrics-4.2 MERGED Remove trailing / from paths in config 2018-06-25 11:58:48 UTC

Description Lukas Svaty 2018-05-09 11:04:05 UTC
Description of problem:
Paths in configs such as 


Must include trailing /, therefore if it is set in the config file without suffix / not desired path can be used. Please support specification of the path without trailing /


Version-Release number of selected component (if applicable):
ovirt-engine-metrics-1.1.4.2-1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.# grep -R ovirt_elasticsearch_mounted_storage_path /usr/share/ansible/roles/oVirt.metrics/roles/oVirt.metrics-store-installation/README.md


Actual results:
`ovirt_elasticsearch_mounted_storage_path:`(default:`/var/lib/`)

Expected results:
`ovirt_elasticsearch_mounted_storage_path:`(default:`/var/lib`)

Additional info:
The same format as engine paths:
]# grep -R PATH  .
./50-ovirt-engine-extension-aaa-jdbc.conf:ENGINE_JAVA_MODULEPATH="${ENGINE_JAVA_MODULEPATH}:/usr/share/ovirt-engine-extension-aaa-jdbc/modules"

Comment 1 Shirly Radco 2018-06-25 11:57:04 UTC
To test, after exchanging the keys between engine machine and the metrics store machine, please run  /usr/share/ovirt-engine-metrics/configure_ovirt_machines_for_metrics.sh --playbook=ovirt-metrics-store-installation.yml from the engine machine.

Please make sure that the ansible-inventory are created under the /root directory on the metrics store machine and that the path in the files for the path is still as expected:
openshift_logging_elasticsearch_hostmount_path=/var/lib/elasticsearch

Comment 2 Sandro Bonazzola 2018-07-31 15:31:36 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.