Bug 1576407 - ctrl-shift-e for terminator gets intercepted for emoji
Summary: ctrl-shift-e for terminator gets intercepted for emoji
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: terminator
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 11:51 UTC by A.J. Bonnema
Modified: 2018-05-15 12:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 12:16:29 UTC
Type: ---


Attachments (Terms of Use)

Description A.J. Bonnema 2018-05-09 11:51:02 UTC
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build Identifier: 

The keys ctrl-shift-e in terminator are meant to do a vertical screen split when terminator is open and has focus. In stead some emoji dialog is opened that is useless from the perspective of using terminator.

How can I prevent the system from intercepting the key combo ctrl-shift-e?

Reproducible: Always

Steps to Reproduce:
1. Open terminator
2. press ctrl-shift-e while terminator has focus.
3.
Actual Results:  
The dialog for an emoji choice opens.

Expected Results:  
A vertical screen split (two terminals within terminator).

I would very much like to know how Terminator can be made to receive the key combi ctrl-shift-e. 

I tried to find out whether the key is part of settings, but apparantly not, I can not find it. Neither in gnome settings, nor in tweak settings. Also, I can not find the binary responsible for the interception. Finally, I cannot find which package is responsible for the interception.

Even though there is a workaround (using the mouse) I consider this a bug, because when typing in a terminal I want to avoid using the mouse. It is very annoying if I am forced to using the mouse. I sincerely hope there is an easy fix, like some setting I am not aware of, or removing a package.

Comment 1 A.J. Bonnema 2018-05-09 11:52:16 UTC
I found the bug after upgrading to Fedora 28. Using Fedora 27 this was not a problem.

Comment 2 Dominic Hopf 2018-05-11 08:11:54 UTC
That sounds very much like a window manager is catching the key binding before it even arrives at terminator itself. Using Xfce (and thus, xfwm4 as window manager) i don't even know that a emoji selector exists in some kind. o.O

Understanding that you're using GNOME or something related, I'd suggest to recheck the settings again. Unfortunately, since I'm not a GNOME user, I cannot say, where to search exactly.

Comment 3 A.J. Bonnema 2018-05-11 09:10:58 UTC
It is gnome. However, neither the gnome settings nor the tweaking utility mention this shortcut. I mention that in the original description. If it was a simple setting I would have no problem. AFAICS it is not, unfortunately.

Because it is not in the gnome settings anywhere, I suspect it is hidden in ibus, because the emoji input dialog comes from ibus.

I wonder whether other people using gnome have the same issue. It is a fairly new bug, since Fedora 28, so it will take time for people to report it, I guess.

Comment 4 Francisco Garcia 2018-05-15 11:36:28 UTC
It seems this is a new feature brought by Fedora 28:

https://fedoraproject.org/wiki/Changes/IBus_Unicode_Typing

if you `man ibus-emoji` :

...
KEYBOARD OPERATIONS
       Control-Shift-e
              Launch IBus Emojier. The shortcut key can be customized by ibus-setup (1).
...


Fun thing, my system does _not_ show any emoji chooser albeit with its current config it should. Nevertheless I think this can be closed with NOTABUG :) 

Cheers

Fran

Comment 5 A.J. Bonnema 2018-05-15 12:11:58 UTC
(In reply to Francisco Garcia from comment #4)
> It seems this is a new feature brought by Fedora 28:
> 
> https://fedoraproject.org/wiki/Changes/IBus_Unicode_Typing
> 
> if you `man ibus-emoji` :
> 
> ...
> KEYBOARD OPERATIONS
>        Control-Shift-e
>               Launch IBus Emojier. The shortcut key can be customized by
> ibus-setup (1).
> ...

Thank you very much for this solution. It works. I have been able to delete the shortcut as I have no need for the emoji input dialog. 

> 
> 
> Fun thing, my system does _not_ show any emoji chooser albeit with its
> current config it should. Nevertheless I think this can be closed with
> NOTABUG :) 

I agree that it is thechnically not a bug, but it is pretty annoying if it gets in the way of my daily work with Fedora and Terminator. I am very glad though that you found where to disable the shortcut.

I do wonder why this dialog is on by default for everyone, especially if it interferes with other programs.

So, rant aside, I agree, this is not a bug of Terminator. Not sure if I should change the status tho, let me know if I should.

Comment 6 Dominic Hopf 2018-05-15 12:16:29 UTC
Thanks for pointing this out Francisco! I wouldn't have any idea about this. :-)


Note You need to log in before you can comment on or make changes to this bug.