Bug 1576427 - FFU: neutron-db-manage upgrade head fails during OSP12 upgrade with: alembic.script.revision.ResolutionError: No such revision or branch '66cc6bc031de'
Summary: FFU: neutron-db-manage upgrade head fails during OSP12 upgrade with: alembic....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-bigswitch
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: async
: 12.0 (Pike)
Assignee: RHOS Maint
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks: 1573353
TreeView+ depends on / blocked
 
Reported: 2018-05-09 12:40 UTC by Mike Burns
Modified: 2018-05-24 17:18 UTC (History)
11 users (show)

Fixed In Version: python-networking-bigswitch-11.47.2-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1573353
Environment:
Last Closed: 2018-05-24 17:18:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1719 0 None None None 2018-05-24 17:18:29 UTC

Description Mike Burns 2018-05-09 12:40:42 UTC
Cloning this to OSP 12.  The fix for the issue needs to land in OSP 12.  

+++ This bug was initially created as a clone of Bug #1573353 +++

Description of problem:
FFU: neutron-db-manage upgrade head fails during OSP12 upgrade with: alembic.script.revision.ResolutionError: No such revision or branch '66cc6bc031de':

[root@controller-0 heat-admin]# neutron-db-manage upgrade head 
INFO  [alembic.runtime.migration] Context impl MySQLImpl.
INFO  [alembic.runtime.migration] Will assume non-transactional DDL.
  Running upgrade for neutron ...
INFO  [alembic.runtime.migration] Context impl MySQLImpl.
INFO  [alembic.runtime.migration] Will assume non-transactional DDL.
  OK
INFO  [alembic.runtime.migration] Context impl MySQLImpl.
INFO  [alembic.runtime.migration] Will assume non-transactional DDL.
Traceback (most recent call last):
  File "/bin/neutron-db-manage", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/site-packages/neutron/db/migration/cli.py", line 687, in main
    return_val |= bool(CONF.command.func(config, CONF.command.name))
  File "/usr/lib/python2.7/site-packages/neutron/db/migration/cli.py", line 206, in do_upgrade
    run_sanity_checks(config, revision)
  File "/usr/lib/python2.7/site-packages/neutron/db/migration/cli.py", line 671, in run_sanity_checks
    script_dir.run_env()
  File "/usr/lib/python2.7/site-packages/alembic/script/base.py", line 407, in run_env
    util.load_python_file(self.dir, 'env.py')
  File "/usr/lib/python2.7/site-packages/alembic/util/pyfiles.py", line 93, in load_python_file
    module = load_module_py(module_id, path)
  File "/usr/lib/python2.7/site-packages/alembic/util/compat.py", line 79, in load_module_py
    mod = imp.load_source(module_id, path, fp)
  File "/usr/lib/python2.7/site-packages/networking_bigswitch/plugins/bigswitch/db/migration/alembic_migrations/env.py", line 86, in <module>
    run_migrations_online()
  File "/usr/lib/python2.7/site-packages/networking_bigswitch/plugins/bigswitch/db/migration/alembic_migrations/env.py", line 77, in run_migrations_online
    context.run_migrations()
  File "<string>", line 8, in run_migrations
  File "/usr/lib/python2.7/site-packages/alembic/runtime/environment.py", line 797, in run_migrations
    self.get_context().run_migrations(**kw)
  File "/usr/lib/python2.7/site-packages/alembic/runtime/migration.py", line 303, in run_migrations
    for step in self._migrations_fn(heads, self):
  File "/usr/lib/python2.7/site-packages/neutron/db/migration/cli.py", line 662, in check_sanity
    revision, rev, implicit_base=True):
  File "/usr/lib/python2.7/site-packages/alembic/script/revision.py", line 641, in _iterate_revisions
    requested_lowers = self.get_revisions(lower)
  File "/usr/lib/python2.7/site-packages/alembic/script/revision.py", line 298, in get_revisions
    return sum([self.get_revisions(id_elem) for id_elem in id_], ())
  File "/usr/lib/python2.7/site-packages/alembic/script/revision.py", line 303, in get_revisions
    for rev_id in resolved_id)
  File "/usr/lib/python2.7/site-packages/alembic/script/revision.py", line 303, in <genexpr>
    for rev_id in resolved_id)
  File "/usr/lib/python2.7/site-packages/alembic/script/revision.py", line 358, in _revision_for_ident
    resolved_id)
alembic.script.revision.ResolutionError: No such revision or branch '66cc6bc031de'


Version-Release number of selected component (if applicable):
python-networking-bigswitch-11.0.3-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10
2. Run FFU procedure

Actual results:
While upgrading the controller to OSP12  neutron-db-manage upgrade head fails.

Expected results:
No failure.

Additional info:

--- Additional comment from bigswitch on 2018-05-01 10:30:37 EDT ---

Hi,

This seems to be due to a stale plugin version '11.0.3' as seen in the package name 'python-networking-bigswitch-11.0.3-1.el7ost.noarch'.

There was a change that updated DB scripts and the tagged version for that change was 11.0.4.

And looking at the tagged releases, the latest was pushed recently: 11.47.1 (*minor version follows the BCF release number. It was previously 0 because it was in QA phase).

How can we update the package version used/present in the ISO image used for installation?
During local deployment, our deployment guide has a step to update the networking-bigswitch package in the ISO image to the latest using virt-customize.

I believe we did something similar during OSP 10 and 11 as well.
Hope the above info helps. Let me know if I can provide any more info.

Thanks!
- Aditya

--- Additional comment from Marios Andreou on 2018-05-07 08:43:43 EDT ---

lbezdick can you please triage this (from triage call round robin)

Comment 8 errata-xmlrpc 2018-05-24 17:18:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1719


Note You need to log in before you can comment on or make changes to this bug.