Bug 1576429 - API content-view version info does not require mandatory organization
Summary: API content-view version info does not require mandatory organization
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API - Content
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2018-05-09 12:41 UTC by Peter Vreman
Modified: 2019-08-12 14:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-02 17:53:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Peter Vreman 2018-05-09 12:41:35 UTC
Description of problem:
The API of content-view version info (called from hammer) does not require the mandatory organization.
This results in wrong behaviour: 
- Specifying incorrect version is specified then an incorrect error because the filter is missing the organization.
- Specifying a version that is also in an other content view version available it returns error that more than one found

Without organization
-----------------------------------------------
[crash/LI] root@li-lc-1578:~# sudo -u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 999
Error: one of content_view_versions not found

[crash/LI] root@li-lc-1578:~# sudo -u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 2
Error: found more than one content_view_version

# Now (with luck) a version that is unique for all CVV returns the data:
crash/LI] root@li-lc-1578:~# sudo -u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 19 | grep '^[^ ]'
ID:                     1244
Name:                   hgp-crash:sat-6.3-ci 19.0
Version:                19.0
Description:
Content View ID:        126
Content View Name:      hgp-crash:sat-6.3-ci
Content View Label:     hgp-crash_sat-6_3-ci
Lifecycle Environments:
Repositories:
Puppet Modules:
-----------------------------------------------

Now adding the correct Organization:
-----------------------------------------------
[crash/LI] root@li-lc-1578:~# sudo -u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 999 --organization Hilti
Error: content_view not found

[crash/LI] root@li-lc-1578:~# sudo -u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 2 --organization Hilti
Error: content_view not found
-----------------------------------------------


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. See calls in description
2.
3.

Actual results:
Unexpected results or incorrect errors

Expected results:
Correct results and errors

Additional info:

Comment 1 Peter Vreman 2018-05-09 12:47:20 UTC
Note that in the tests i even made a typo in the content_view name and it returned the content_view_vesions messages instead of the content_view missing

A correct test that has valid error of content_view_versions was:


[crash/LI] root@li-lc-1578:~# sudo -u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view hgp-crash:sat-6.3-ci --version 999 --organization Hilti
Error: one of content_view_versions not found

Comment 3 Bryan Kearney 2019-07-02 17:53:26 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.