Bug 1576459 - Edit Parameters on multiple nodes is failing when one host does not have the parameter
Summary: Edit Parameters on multiple nodes is failing when one host does not have the ...
Keywords:
Status: CLOSED DUPLICATE of bug 1458273
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Parameters
Version: 6.3.1
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 13:50 UTC by Simon Reber
Modified: 2019-08-12 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-11 17:21:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Simon Reber 2018-05-09 13:50:23 UTC
Description of problem:

When selecting multiple hosts in the Hosts overview and selecting "Edit Parameters" I can see the parameters I can edit on these Hosts/selection.

The thing is, the bulk action does not recognize when one of the nodes selected does not have that parameter set. So once the value is set and submit is executed an error is reported.

2018-05-09 14:40:36 d2ca410f [app] [I] Started POST "/hosts/update_multiple_parameters?host_ids%5B%5D=24&host_ids%5B%5D=25" for 10.36.116.96 at 2018-05-09 14:40:36 +0100
2018-05-09 14:40:36 d2ca410f [app] [I] Processing by HostsController#update_multiple_parameters as HTML
2018-05-09 14:40:36 d2ca410f [app] [I]   Parameters: {"utf8"=>"✓", "authenticity_token"=>"mRJuI7IlQbXiZ1PB4rlaz1wIwRawE8BjW27UA1a6/NcdkWCOTZibfcapOWZfRWO4fTm0vSbDQ1Ne4oEsK6bGMw==", "name"=>{"Raiffeisen"=>"Top"}, "host_ids"=>["24", "25"]}
2018-05-09 14:40:36 d2ca410f [app] [I] Current user: admin (administrator)
2018-05-09 14:40:36 d2ca410f [app] [I] Expire fragment views/tabs_and_title_records-3 (0.1ms)
2018-05-09 14:40:36 d2ca410f [app] [I]   Rendered common/404.html.erb within layouts/application (4.3ms)
2018-05-09 14:40:36 d2ca410f [app] [I]   Rendered layouts/_application_content.html.erb (0.6ms)
2018-05-09 14:40:36 d2ca410f [app] [I]   Rendered layouts/base.html.erb (3.1ms)
2018-05-09 14:40:36 d2ca410f [app] [I] Completed 404 Not Found in 63ms (Views: 9.9ms | ActiveRecord: 6.8ms)
2018-05-09 14:40:37 52f7f57f [app] [I] Started GET "/notification_recipients" for 10.36.116.96 at 2018-05-09 14:40:37 +0100
2018-05-09 14:40:37 52f7f57f [app] [I] Processing by NotificationRecipientsController#index as JSON
2018-05-09 14:40:37 52f7f57f [app] [I] Current user: admin (administrator)
2018-05-09 14:40:37 52f7f57f [app] [I] Expire fragment views/tabs_and_title_records-3 (0.1ms)
2018-05-09 14:40:37 52f7f57f [app] [I] Completed 200 OK in 10ms (Views: 0.1ms | ActiveRecord: 0.7ms)

Version-Release number of selected component (if applicable):

 - satellite-6.3.1-3.el7sat.noarch

How reproducible:

 - Always

Steps to Reproduce:
1. Set Parameter Test on HostA
2. Do not set Parameter Test on HostB
3. Select HostA and HostB and run "Edit Parameters"
4. Set a value and hit "Submit"

Actual results:

A failure is reported, telling the host is not found

Expected results:

No error reported or else highlight that HostB does not have the parameter and thus can't be included in the current action/selection

Additional info:

Not sure if it's related to https://bugzilla.redhat.com/show_bug.cgi?id=1458273

Comment 2 orabin 2018-05-11 17:21:02 UTC
It looks like it's the same as the bug referenced to.
If there is more information to add, please update: https://bugzilla.redhat.com/show_bug.cgi?id=1458273

*** This bug has been marked as a duplicate of bug 1458273 ***


Note You need to log in before you can comment on or make changes to this bug.