Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1576472 - [RFE] Disable dirty iSCSI LUNs
Summary: [RFE] Disable dirty iSCSI LUNs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: 0.11.20
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-4.2.5
: ---
Assignee: Phillip Bailey
QA Contact: Yihui Zhao
URL:
Whiteboard:
Depends On:
Blocks: cockpit-ovirt-0.11.30
TreeView+ depends on / blocked
 
Reported: 2018-05-09 14:37 UTC by Phillip Bailey
Modified: 2018-07-31 15:24 UTC (History)
10 users (show)

Fixed In Version: cockpit-ovirt-0.11.26-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 15:24:56 UTC
oVirt Team: Integration
rbarry: ovirt-4.2?
rule-engine: planning_ack?
rule-engine: devel_ack+
cshao: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91715 0 master MERGED wizard: Disable dirty iSCSI & FC LUNs 2020-11-22 04:54:28 UTC
oVirt gerrit 91802 0 ovirt-4.2 MERGED wizard: Disable dirty iSCSI & FC LUNs 2020-11-22 04:54:29 UTC

Description Phillip Bailey 2018-05-09 14:37:28 UTC
Description of problem:
Hosted engine installation will fail if a dirty iSCSI LUN is selected, but the user isn't informed about this until the create_storage_domains playbook is started and fails.


Version-Release number of selected component (if applicable):
cockpit-ovirt-0.11.23-1

How reproducible:
100%


Steps to Reproduce:
1. Run the hosted engine setup wizard in Cockpit
2. In the Storage step, select 'iSCSI' for the storage type
3  Enter the portal IP address
4. Click the "Retrieve Target List" button
5. Select the target with the dirty LUN from the list
6. Select the LUN marked as "used"
7. Click the "Next" button
8. Click the "Finish Deployment" button

Actual results:
Installation will fail with the error message:

Fault detail is "[Physical device initialization failed. Please check that the device is empty and accessible by the host.]"

Expected results:
Any LUNs that are unable to be used for setup should be disabled with an explanation.

Comment 1 Sandro Bonazzola 2018-06-29 15:09:18 UTC
Can be tested with 4.2.4 ISO.

Comment 2 cshao 2018-07-02 02:54:39 UTC
Yihui,

Could you please help to verify this bug according #c1?

Thanks.

Comment 3 Yihui Zhao 2018-07-02 05:37:08 UTC
Tested with cockpit-ovirt-dashboard-0.11.29-1.el7ev.noarch , if the iscsi target is in use, it didn't select again. And give the warning
"""
This LUN cannot be selected because it appears to be already in use. Please clean it and try again.
"""

So, change this bug's status to verified.

Comment 4 Sandro Bonazzola 2018-07-31 15:24:56 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.