Bug 1576553 - [DR] - Fail back cleans storage domains which are not active, even if they are not written in the mapped var file
Summary: [DR] - Fail back cleans storage domains which are not active, even if they ar...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-ansible-collection
Classification: oVirt
Component: disaster-recovery
Version: 1.1.4
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Maor
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On:
Blocks: 1582073
TreeView+ depends on / blocked
 
Reported: 2018-05-09 17:49 UTC by Elad
Modified: 2018-06-26 08:46 UTC (History)
2 users (show)

Fixed In Version: ovirt-ansible-disaster-recovery-1.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:46:05 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github oVirt ovirt-ansible-disaster-recovery pull 49 0 None None None 2018-05-14 00:23:02 UTC

Description Elad 2018-05-09 17:49:10 UTC
Description of problem:
Following bug 1533385, fail back won't clean a domain during fail back, only in case this domain is active.
If the domain is in another status, maintenance for example, this domain will go through clean up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Call fail back for a target setup that some of its storage domains are not written in the mapping var file and these domains are in maintenance

Actual results:
Fail back cleans the domains in maintenance even though they are written in the mapping var file


Expected results:
Fail back shouldn't clean these domains.

Additional info:

Comment 1 Elad 2018-05-09 17:49:43 UTC
Version-Release number of selected component (if applicable):
ovirt-ansible-disaster-recovery-0.4-1.el7ev.noarch
ansible-2.5.2-1.el7ae.noarch

Comment 2 Kevin Alon Goldblatt 2018-06-10 15:01:54 UTC
Verified with the following code:
---------------------------------------------------
ovirt-engine-4.2.4.1-0.1.el7.noarch
vdsm-4.20.29-1.el7ev.x86_64
ovirt-ansible-disaster-recovery-1.1.0-1.el7ev.noarch


Verified with the following scenario:
---------------------------------------------------
Steps to Reproduce:
1. Call fail back for a target setup that some of its storage domains are not written in the mapping var file and these domains are in maintenance

Actual results:
Fail back NO LONGER cleans the domains in maintenance that are not written in the mapping var file


Moving to VERIFIED

Comment 3 Sandro Bonazzola 2018-06-26 08:46:05 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.