Bug 1576579 - nut RPM doesn't like new version of libfreeipmi RPM
Summary: nut RPM doesn't like new version of libfreeipmi RPM
Keywords:
Status: CLOSED DUPLICATE of bug 1570146
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nut
Version: epel7
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 20:14 UTC by nomad
Modified: 2018-05-11 13:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-11 13:55:30 UTC
Type: Bug


Attachments (Terms of Use)

Description nomad 2018-05-09 20:14:40 UTC
Description of problem:
yum update to latest release fails if nut RPM is installed because of missing dependency on old version of libfreeipmi. libfreeipmi is updated but nut isn't.

Also, can't install nut RPM on host with latest freeipmi RPM.

Version-Release number of selected component (if applicable):
nut-2.7.2-3.el7.x86_64
freeipmi-1.5.7-2.el7.x86_64

How reproducible:
very

Steps to Reproduce:
1. yum install nut
2. 
3.

Actual results:
; sudo yum install nut
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package nut.x86_64 0:2.7.2-3.el7 will be installed
--> Processing Dependency: libipmimonitoring.so.5()(64bit) for package: nut-2.7.2-3.el7.x86_64
--> Processing Dependency: libfreeipmi.so.13()(64bit) for package: nut-2.7.2-3.el7.x86_64
--> Finished Dependency Resolution
Error: Package: nut-2.7.2-3.el7.x86_64 (EPELpkgs)
           Requires: libfreeipmi.so.13()(64bit)
Error: Package: nut-2.7.2-3.el7.x86_64 (EPELpkgs)
           Requires: libipmimonitoring.so.5()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
nut RPM installed

Additional info:

Comment 1 Patrick MacArthur 2018-05-10 15:21:07 UTC
This appears to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1570146 which I filed several weeks ago. I have not yet received any response on that issue.

Comment 2 Vadim Raskhozhev 2018-05-10 15:37:58 UTC
(In reply to Patrick MacArthur from comment #1)
> This appears to be a duplicate of
> https://bugzilla.redhat.com/show_bug.cgi?id=1570146 which I filed several
> weeks ago.
Yes, it seems.
A possible work-around for CentOS: yum --enablerepo 'C7.*' install nut

Comment 3 nomad 2018-05-10 17:20:36 UTC
Sorry about the duplication. I swear I looked. I'm fine with the two reports being merged or this one being closed as a duplicate, as long as a fix happens. :)

Comment 4 Vadim Raskhozhev 2018-05-10 19:03:32 UTC
(In reply to nomad from comment #3)
> Sorry about the duplication. I swear I looked. I'm fine with the two reports
> being merged or this one being closed as a duplicate, as long as a fix
> happens. :)

I guess it'd be better to close the #1570146 since we've got a sort of discussion here and not a single comment there. But I'm not the one to decide, of course.

Comment 5 Josh Stone 2018-05-10 22:06:22 UTC
A new scratch-build completed fine without any changes:
https://koji.fedoraproject.org/koji/taskinfo?taskID=26881241

A "provenpackager" could push this out if the package owner is not responsive.

Comment 6 Michal Hlavinka 2018-05-11 13:55:30 UTC

*** This bug has been marked as a duplicate of bug 1570146 ***


Note You need to log in before you can comment on or make changes to this bug.