Bug 1576580 - Attempting to Deploy RHOSP-11 with NetApp Driver Causes Failure in Overcloud Deploy
Summary: Attempting to Deploy RHOSP-11 with NetApp Driver Causes Failure in Overcloud ...
Keywords:
Status: CLOSED DUPLICATE of bug 1577957
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Emilien Macchi
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 20:20 UTC by Vince Green
Modified: 2018-05-14 16:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 16:35:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
failure of logs from the deployment (6.16 KB, text/plain)
2018-05-09 20:20 UTC, Vince Green
no flags Details

Description Vince Green 2018-05-09 20:20:17 UTC
Created attachment 1434005 [details]
failure of logs from the deployment

Output of "openstack stack failures list"

Description of problem:
When attempting to deploy OSP-11z5 with with the NetApp cDOT Manila Driver, the overcloud deployment will fail with an error specifying that there is no value for the data item manila::backend::cephfsnative::cephfs_auth_id. It says that there is no value for it in any Heira data file and that no default is specified. This causes the deployment of the controller nodes to fail. See the attached output of "openstack stack failures list overcloud" for more details.

Similar to bug 1576577.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.2.12-2.el7ost.noarch
puppet-manila-10.4.0-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Using Infrared, deploy the candidate for OSP-10z8 specifying to setup and configure Manila with the Netapp cDOT Manila Driver
2. Observe that the overcloud deployment fails with the errors specified above when setting up the controller nodes.

Actual results:
Overcloud deployment fails because the controller node deployment fails due to the manila::backend::cephfsnative::cephfs_auth_id variable not having a value either specified in any Heira file or set by default. 

Expected results:
Overcloud deployment shall be successful and the Manila NetApp cDOT Driver shall be setup and configured correctly.

Log will be attached

Comment 2 Giulio Fidente 2018-05-14 16:35:43 UTC

*** This bug has been marked as a duplicate of bug 1577957 ***


Note You need to log in before you can comment on or make changes to this bug.