Bug 1576585 - mount.vboxsf missing
Summary: mount.vboxsf missing
Keywords:
Status: CLOSED DUPLICATE of bug 1576832
Alias: None
Product: Fedora
Classification: Fedora
Component: virtualbox-guest-additions
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 21:00 UTC by Lyonel Vincent
Modified: 2018-05-12 02:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-12 02:41:57 UTC


Attachments (Terms of Use)

Description Lyonel Vincent 2018-05-09 21:00:09 UTC
Description of problem:

unable to mount shared folders in guest


Version-Release number of selected component (if applicable):

virtualbox-guest-additions-5.2.10-1.fc28.x86_64

How reproducible:

every time

Steps to Reproduce:
1. do NOT install guest additions from VirtualBox's ISO (i.e. "Insert Guest additions CD image" in the "Devices" menu) 
2. share a folder
3. try to mount that folder inside the guest: mount -t vboxsf SHAREDFOLDER /mnt

Actual results:

error: vboxsf wrong fs type, bad option, bad superblock on support, missing codepage or helper program, or other error.

Expected results:

shared folder mounted on /mnt

Additional info:

Comment 1 Hans de Goede 2018-05-10 08:29:24 UTC
mount.vboxsf is no longer necessary, the latest version of the vboxsf kernel module works with the standard mount utility.

The problem is that the Fedora 28 kernel includes the vboxvideo and vboxguest drivers as those are part of the mainline kernel now. But the vboxsf driver has not been merged into the mainline kernel yet (this is being worked on).

A version of vboxsf compatible with the mainline kernel version of vboxguest is available in rpmfusion, follow the instructions for enabling rpmfusion-free here:
https://rpmfusion.org/Configuration

And then do:

dnf install akmod-VirtualBox

After that: "mount -t vboxsf SHAREDFOLDER /mnt" should work.

Comment 2 Eli Young 2018-05-11 22:07:54 UTC
(In reply to Hans de Goede from comment #1)
> mount.vboxsf is no longer necessary, the latest version of the vboxsf kernel
> module works with the standard mount utility.
> 
> The problem is that the Fedora 28 kernel includes the vboxvideo and
> vboxguest drivers as those are part of the mainline kernel now. But the
> vboxsf driver has not been merged into the mainline kernel yet (this is
> being worked on).

This implies to me that, at least for Fedora 28, mount.vboxsf is still
necessary. As it stands, Fedora 28 doesn't support mounting VirtualBox shared
folders despite appearing to provide first-party support for acting as a VBox
guest. While installing the kernel module from RPM Fusion is an option, it
shouldn't be necessary. IMO, mount.vboxsf shouldn't be removed from Fedora
until the kernel driver ships inside a Fedora kernel.

Comment 3 Sergio Monteiro Basto 2018-05-12 01:45:39 UTC
to mount.vboxsf work you also need vboxsf.ko kernel module

Comment 4 Sergio Monteiro Basto 2018-05-12 02:41:57 UTC

*** This bug has been marked as a duplicate of bug 1576832 ***


Note You need to log in before you can comment on or make changes to this bug.