Bug 1576592 - when networkConfig.clusterNetworks doesn't exist we error out
Summary: when networkConfig.clusterNetworks doesn't exist we error out
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Gan Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 21:18 UTC by Scott Dodson
Modified: 2018-07-30 19:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:17 UTC

Description Scott Dodson 2018-05-09 21:18:49 UTC
TASK [set_fact] ****************************************************************
Wednesday 09 May 2018  21:03:54 +0000 (0:00:00.104)       0:00:08.970 ********* 
fatal: [free-int-master-3c664]: FAILED! => {"msg": "The field 'vars' has an invalid value, which includes an undefined variable. The error was: 'dict object' has no attribute 'clusterNetworks'\n\nThe error appears to have been in '/home/opsmedic/aos-cd/tmp/openshift-ansible-bqFMlq/playbooks/init/basic_facts.yml': line 84, column 5, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n  - set_fact:\n    ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: 'dict object' has no attribute 'clusterNetworks'"}
fatal: [free-int-master-de987]: FAILED! => {"msg": "The field 'vars' has an invalid value, which includes an undefined variable. The error was: 'dict object' has no attribute 'clusterNetworks'\n\nThe error appears to have been in '/home/opsmedic/aos-cd/tmp/openshift-ansible-bqFMlq/playbooks/init/basic_facts.yml': line 84, column 5, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n  - set_fact:\n    ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: 'dict object' has no attribute 'clusterNetworks'"}
fatal: [free-int-master-5470f]: FAILED! => {"msg": "The field 'vars' has an invalid value, which includes an undefined variable. The error was: 'dict object' has no attribute 'clusterNetworks'\n\nThe error appears to have been in '/home/opsmedic/aos-cd/tmp/openshift-ansible-bqFMlq/playbooks/init/basic_facts.yml': line 84, column 5, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n  - set_fact:\n    ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: 'dict object' has no attribute 'clusterNetworks'"}

Comment 2 Michael Gugino 2018-05-10 15:07:48 UTC
PR Created: https://github.com/openshift/openshift-ansible/pull/8325

Comment 4 Gan Huang 2018-05-16 07:16:04 UTC
I assume the reproducible step is to create 3.6 cluster, then upgrade to 3.10 step by step.

Comment 5 Michael Gugino 2018-05-16 14:42:31 UTC
(In reply to Gan Huang from comment #4)
> I assume the reproducible step is to create 3.6 cluster, then upgrade to
> 3.10 step by step.

Yes, or make some edits to the master config file outside of openshift-ansible; the deprecated values should still function correctly.

Comment 6 Gan Huang 2018-05-17 03:27:01 UTC
Install 3.9 cluster, and remove the following lines from master-config.yaml

>   clusterNetworks:
>   - cidr: 10.128.0.0/14
>     hostSubnetLength: 9


Then upgrade to 3.10 by using openshift-ansible-3.10.0-0.47.0.git.0.c018c8f.el7.noarch.rpm successfully.

Comment 8 errata-xmlrpc 2018-07-30 19:14:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.