Bug 1576669 - proxy environments variables should be set in master and docker-registry configurations
Summary: proxy environments variables should be set in master and docker-registry conf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 06:17 UTC by Gan Huang
Modified: 2018-07-30 19:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:17 UTC

Description Gan Huang 2018-05-10 06:17:56 UTC
Description of problem:
proxy environments variables should be set in master and docker-registry configurations.

Version-Release number of the following components:
openshift-ansible-3.10.0-0.38.0.git.7.848b045.el7.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. Trigger installation with proxy variables set.
2.
3.

Actual results:
Installation succeeded. But proxy variables were missing in following configurations:

# oc env dc/docker-registry --list

# proxy setting should be set in admissionConfig.pluginConfig.BuildDefaults in /etc/origin/master/master-config.yaml

admissionConfig:
  pluginConfig:
    BuildDefaults:
    

# /etc/origin/master/master.env



Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 Gan Huang 2018-05-15 04:56:38 UTC
Manually adding proxy variables really annoying though it's not blocker. Reset the priority.

Comment 4 Weihua Meng 2018-05-15 08:39:55 UTC
It is not easy to work around, keep config consistent, especially cluster with numbers of nodes.
add testblocker keyword.

Comment 5 Scott Dodson 2018-05-16 13:40:32 UTC
Suspicion is that this is related to our removal of the openshift facts files during node bootstrapping.

Comment 6 Michael Gugino 2018-05-16 19:06:06 UTC
Possible Fix: https://github.com/openshift/openshift-ansible/pull/8394

Comment 7 Wei Sun 2018-05-22 01:22:36 UTC
The PR 8394 has been merged to 3.10.0-0.50.0,please check this bug.

Comment 10 errata-xmlrpc 2018-07-30 19:14:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.