Bug 1576686 - Failed to deploy RHOS-11 with custom stack's name
Summary: Failed to deploy RHOS-11 with custom stack's name
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 07:19 UTC by Yurii Prokulevych
Modified: 2018-05-10 14:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1576700 (view as bug list)
Environment:
Last Closed: 2018-05-10 14:50:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yurii Prokulevych 2018-05-10 07:19:56 UTC
Description of problem:
-----------------------
Installation of overcloud with custom stack name fails:

openstack overcloud deploy \
--timeout 100 \
--templates /usr/share/openstack-tripleo-heat-templates \
--stack qe_Cloud-0 \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e /home/stack/virt/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /home/stack/virt/enable-tls.yaml \
-e /home/stack/virt/inject-trust-anchor.yaml \
-e /home/stack/virt/public_vip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/tls-endpoints-public-ip.yaml \
-e /home/stack/virt/hostnames.yml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/custom_hostnames.yaml \
-e /home/stack/virt/nodes_data.yaml

Unable to create plan. Unable to create plan. The plan name must only contain letters, numbers or dashes
Creating Swift container to store the plan


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-tripleo-heat-templates.noarch 6.2.12-2.el7ost 
python-tripleoclient.noarch             6.2.4-1.el7ost

Steps to Reproduce:
-------------------
1. Deploy OC with custom stack name with numbers/dashes/underscore

Actual results:
---------------
Deployment fails


Expected results:
-----------------
Deployment succeeds


Additional info:
----------------
Same value for stack's name works on RHOS-10

openstack overcloud deploy \
--timeout 100 \
--templates /usr/share/openstack-tripleo-heat-templates \
--stack qe_Cloud-0 \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
--control-scale 3 \
--control-flavor baremetal \
--compute-scale 2 \
--compute-flavor baremetal \
--ceph-storage-scale 3 \
--ceph-storage-flavor baremetal \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e /home/stack/virt/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /home/stack/virt/enable-tls.yaml \
-e /home/stack/virt/inject-trust-anchor.yaml \
-e /home/stack/virt/public_vip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/tls-endpoints-public-ip.yaml \
-e /home/stack/virt/hostnames.yml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/custom_hostnames.yaml \
--log-file overcloud_deployment_10.log
[stack@undercloud-0 ~]$ tail overcloud_install.log
2018-05-10 06:56:11Z [qe_Cloud-0.AllNodesDeploySteps.ControllerPostPuppet]: CREATE_COMPLETE  Stack CREATE completed successfully
2018-05-10 06:56:11Z [qe_Cloud-0.AllNodesDeploySteps.ControllerPostPuppet]: CREATE_COMPLETE  state changed
2018-05-10 06:56:11Z [qe_Cloud-0.AllNodesDeploySteps]: CREATE_COMPLETE  Stack CREATE completed successfully
2018-05-10 06:56:11Z [qe_Cloud-0.AllNodesDeploySteps]: CREATE_COMPLETE  state changed
2018-05-10 06:56:12Z [qe_Cloud-0]: CREATE_COMPLETE  Stack CREATE completed successfully

 Stack qe_Cloud-0 CREATE_COMPLETE 

Overcloud Endpoint: https://10.0.0.101:13000/v2.0
Overcloud Deployed

Comment 2 Alex Schultz 2018-05-10 14:50:21 UTC
Underscores are not valid in hostnames (which the stackname is used to populate by default). This validation was added as part of 11 because of this. For that reason it's NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.