Bug 1576717 - Add default job status key and improve locking
Summary: Add default job status key and improve locking
Keywords:
Status: CLOSED DUPLICATE of bug 1571244
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-commons
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Rohan Kanade
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 08:56 UTC by Rohan Kanade
Modified: 2018-05-10 13:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 13:14:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github /Tendrl commons issues 959 0 None None None 2018-05-10 08:56:41 UTC

Description Rohan Kanade 2018-05-10 08:56:41 UTC
Description of problem:
web-admin-tendrl-api does not create a watchable "Job.status" key, hence the backend services are not able to lock them correctly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ImportCluster from UI
2. There can be confusing Job.status because multiple backend services process the same job due to not being able to lock the job.


Actual results:


Expected results:
Only one of the backend service should lock and process the job.

Comment 2 Nishanth Thomas 2018-05-10 13:14:48 UTC

*** This bug has been marked as a duplicate of bug 1571244 ***


Note You need to log in before you can comment on or make changes to this bug.