Bug 1576728 - deprovision failed when create 2 bindings then delete all bindings
Summary: deprovision failed when create 2 bindings then delete all bindings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Shawn Hurley
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 09:16 UTC by Zihan Tang
Modified: 2018-07-30 19:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:17 UTC

Description Zihan Tang 2018-05-10 09:16:32 UTC
Description of problem:
when create 2 bindings for a instance , then delete all bindings , and delete the serviceinstance , the instance can not be delete successfully.


Version-Release number of selected component (if applicable):
1.2.10

How reproducible:
always

Steps to Reproduce:
1.provision postgresql-apb , then create 2 binidings.
2. delete the 2 bindings 
3. delete the serviceinstance.
[root@qe-zitang-gce-2-master-etcd-1 ~]# oc delete servicebinding dh-postgresql-apb-plgxz-9ncn2 dh-postgresql-apb-plgxz-g5k58 -n post2
servicebinding.servicecatalog.k8s.io "dh-postgresql-apb-plgxz-9ncn2" deleted
servicebinding.servicecatalog.k8s.io "dh-postgresql-apb-plgxz-g5k58" deleted

[root@qe-zitang-gce-2-master-etcd-1 ~]# oc get servicebindings -n post2
No resources found.
[root@qe-zitang-gce-2-master-etcd-1 ~]# oc delete serviceinstance dh-postgresql-apb-plgxz -n post2
serviceinstance.servicecatalog.k8s.io "dh-postgresql-apb-plgxz" deleted


Actual results:
delete failed.
ASB log error :
10.128.0.1 - - [10/May/2018:08:30:36 +0000] "DELETE /ansible-service-broker/v2/service_instances/cca6063d-542b-11e8-93b4-0a580a800003/service_bindings/556c6660-542c-11e8-93b4-0a580a800003?plan_id=7f4a5e35e4af2beb70076e72fab0b7ff&service_id=1dda1477cace09730bd8ed7a6505607e HTTP/1.1" 200 3
[2018-05-10T08:30:38.224Z] [ERROR] - unable to get service instance - Operation cannot be fulfilled on bundleinstances.automationbroker.io "cca6063d-542b-11e8-93b4-0a580a800003": the object has been modified; please apply your changes to the latest version and try again
[2018-05-10T08:30:38.224Z] [ERROR] - Failed to delete binding when launch_apb_on_bind is false: Operation cannot be fulfilled on bundleinstances.automationbroker.io "cca6063d-542b-11e8-93b4-0a580a800003": the object has been modified; please apply your changes to the latest version and try again
[2018-05-10T08:30:38.224Z] [ERROR] - Unknown error: Operation cannot be fulfilled on bundleinstances.automationbroker.io "cca6063d-542b-11e8-93b4-0a580a800003": the object has been modified; please apply your changes to the latest version and try again

bundleisntance:
[root@qe-zitang-gce-2-master-etcd-1 ~]# oc describe bundleinstance cca6063d-542b-11e8-93b4-0a580a800003
Name:         cca6063d-542b-11e8-93b4-0a580a800003
Namespace:    openshift-ansible-service-broker
Labels:       <none>
Annotations:  <none>
API Version:  automationbroker.io/v1alpha1
Kind:         BundleInstance
Metadata:
  Cluster Name:        
  Creation Timestamp:  2018-05-10T08:26:13Z
  Generation:          1
  Resource Version:    52425
  Self Link:           /apis/automationbroker.io/v1alpha1/namespaces/openshift-ansible-service-broker/bundleinstances/cca6063d-542b-11e8-93b4-0a580a800003
  UID:                 cd023f03-542b-11e8-bac3-42010af00062
Spec:
  Bundle:
    Name:  1dda1477cace09730bd8ed7a6505607e
  Context:
    Namespace:    post2
    Platform:     kubernetes
  Dashboard URL:  
  Parameters:     {"_apb_last_requesting_user":"zitang2","_apb_plan_id":"dev","_apb_service_class_id":"1dda1477cace09730bd8ed7a6505607e","_apb_service_instance_id":"cca6063d-542b-11e8-93b4-0a580a800003","postgresql_database":"admin","postgresql_password":"dddd","postgresql_user":"admin","postgresql_version":"9.6"}
Status:
  Bindings:
    Name:  531bcf25-542c-11e8-93b4-0a580a800003
  Jobs:
    5 Abec 0 D 1 - Fffd - 4 Fab - 8844 - 13682 Bcdd 364:
      Description:         provision job completed
      Last Modified Time:  2018-05-10T08:26:22Z
      Method:              provision
      Podname:             
      State:               succeeded
  Last Description:        provision job completed
  State:                   succeeded
Events:                    <none>

[root@qe-zitang-gce-2-master-etcd-1 ~]# oc get bundlebindings  -n openshift-ansible-service-broker
No resources found.

binding all deleted , but bundleinstance not updated with 1 binding left.

the serviceinstance pod is left running
[root@qe-zitang-gce-2-master-etcd-1 ~]# oc get serviceinstance -n post
No resources found.
[root@qe-zitang-gce-2-master-etcd-1 ~]# oc get pod -n post
NAME                          READY     STATUS    RESTARTS   AGE
postgresql-9.5-prod-1-nfbcl   1/1       Running   0          29m


Expected results:
deprovision succeed.

Additional info:

Comment 1 John Matthews 2018-05-11 15:16:05 UTC
Shawn,

Please help narrow down if this is an issue in our Broker or should this be reassigned to Service catalog team.

Comment 4 Zihan Tang 2018-05-22 05:58:29 UTC
image is ready, change it to ON_QA

Comment 5 Zihan Tang 2018-05-22 06:02:43 UTC
VERIFIED.
asb version: 1.2.12

Comment 7 errata-xmlrpc 2018-07-30 19:14:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.