Bug 1576749 - not able to work with baseurls containing '@' character
Summary: not able to work with baseurls containing '@' character
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Marek Blaha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 10:30 UTC by clime
Modified: 2018-06-28 08:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-28 08:00:45 UTC
Type: Bug


Attachments (Terms of Use)

Description clime 2018-05-10 10:30:21 UTC
Description of problem:

With dnf-2.8.9, I wasn't able to make baseurls with 'at' character work.

# dnf copr enable @ksh/latest
# dnf install ksh
Repository group_ksh-latest has no mirror or baseurl set.
...

And the repository group_ksh-latest is not used by dnf as a result to search for the ksh package.

After removing '@' character from baseurl, it starts to work but, of course, baseurl is incorrect now.

[root@823ca29ffec3 yum.repos.d]# dnf info ksh
Failed to synchronize cache for repo 'group_ksh-latest', disabling.100% [===================================================================] 981  B/s | 345  B     00:00 ETA

Version-Release number of selected component (if applicable):

Name         : dnf
Version      : 2.8.9
Release      : 0.165g6886a10a.fc27

How reproducible:
always


Actual results:
# dnf install ksh
Repository group_ksh-latest has no mirror or baseurl set.


Expected results:

Repo defined by this defition works and can be synchronized properly:

[group_ksh-latest]
name=Copr repo for latest owned by @ksh
baseurl=https://copr-be.cloud.fedoraproject.org/results/@ksh/latest/fedora-$releasever-$basearch/
type=rpm-md
skip_if_unavailable=True
gpgcheck=1
gpgkey=https://copr-be.cloud.fedoraproject.org/results/@ksh/latest/pubkey.gpg
repo_gpgcheck=0
enabled=1
enabled_metadata=1

Comment 1 Marek Blaha 2018-05-10 20:23:38 UTC
@ character in URL should be (as one of reserved characters) percent encoded. Idealy on copr side. The other thing is that URL containing % char are not recognized by dnf neither ;) This should be fixed by PR https://github.com/rpm-software-management/libdnf/pull/458

Comment 2 Jaroslav Mracek 2018-06-28 08:00:27 UTC
The issue is solved by libdnf-0.15.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.