Bug 1576764 - In OCP+CNS, time synchronization process type differs in both, nodes(chrony) and gluster pods(NTP)
Summary: In OCP+CNS, time synchronization process type differs in both, nodes(chrony) ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-server-container
Version: cns-3.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.10
Assignee: Saravanakumar
QA Contact: Neha Berry
URL:
Whiteboard:
Depends On:
Blocks: 1568861
TreeView+ depends on / blocked
 
Reported: 2018-05-10 11:14 UTC by Neha Berry
Modified: 2019-02-05 06:56 UTC (History)
13 users (show)

Fixed In Version: rhgs-server-rhel7:3.3.1-20
Doc Type: Bug Fix
Doc Text:
Previously, NTP service ran in both rhgs-server-container pod and the node where rhgs-server-container pod was running. With this fix, NTP service is enabled only in the node and the instance that ran in rhgs-server-container pod is removed.
Clone Of:
Environment:
Last Closed: 2018-09-12 10:54:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1537676 0 low CLOSED [RFE] Control whether ntpd can be enabled / disabled on glusterfs pods and be able to specify ntpd servers 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2018:2688 0 None None None 2018-09-12 10:55:15 UTC

Internal Links: 1537676

Description Neha Berry 2018-05-10 11:14:58 UTC
Description of problem:
+++++++++++++++++++++++++++

An OCP+CNS 3.9 setup was created usin advanced installation(ansible) deployment. Ansible file had "openshift_clock_enabled=true" option set and hence we expected NTP to be installed and enabled on each of the participating nodes.

But it is seen that all the Nodes, including nodes on which gluster pods are running, do not have any NTP service installed and enabled. Rather "CHRONY" process is seen to be running for time synchronization.

But in all gluster pods, we have NTP process in running state. 

Hence, wanted to confirm what is the need for two different time synchronization agents and shouldn't it be better to have single type of process, say NTP process, for both nodes and gluster pods.

Gluster pods always come with NTP by default and for the nodes, we are seeing chrony process running.






Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install OCP+CNS using Ansible playbook, with "openshift_clock_enabled=true" setting included in file.
2. Check the process running on both gluster nodes and gluster pods.
3. Checked that chrony is running on nodes and NTP on gluster pods, intead of similar process on both. 

Actual results:
+++++++++++++++++++
The gluster nodes and pods have different time synchronization processes instead of a common type

Expected results:

It would be easy if similar process type is used for both so as to have no time related discrepancies.


Additional info:

Comment 6 Saravanakumar 2018-05-28 07:10:19 UTC
NTP removed from gluster pods.

Also, NTP service(ntpd/chrony) is started in gluster nodes.

By default, all openshift nodes will have NTP service configured.


Corresponding upstream patches:

https://github.com/openshift/openshift-ansible/pull/8374
https://github.com/gluster/gluster-containers/pull/81

Comment 12 Anjana KD 2018-08-31 00:57:29 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 15 errata-xmlrpc 2018-09-12 10:54:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2688


Note You need to log in before you can comment on or make changes to this bug.