Bug 157677 - cs4232 skips/stutters under play, XMMS fails, CDs play OK
cs4232 skips/stutters under play, XMMS fails, CDs play OK
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-13 13:32 EDT by Landon Curt Noll
Modified: 2012-01-22 21:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-22 21:35:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Landon Curt Noll 2005-05-13 13:32:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Per request from zaitcev@redhat.com, bug #53293
was re-opened for RHEL 4.

I am running RH 7.1 on an IBM ThinkPad 770Z and a cs4232 sound chip.
UnderRH7.1 the CD plays music just fine.  However sound programs such
as play or XMMS either fail to play anything at all or what they produce
skips and stuffers so bad as to be unrecognizable.

This same lack of sound problem exists in RHEL3 WS. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.see bug #53293
2.
3.
  

Actual Results:  see bug #53293

Expected Results:  see bug #53293

Additional info:

see bug #53293
Comment 1 Pete Zaitcev 2005-05-13 14:23:28 EDT
What is the exact version of kernel and pcmcia-cs on the box?
Please run rpm -q kernel and rpm -q pcmcia-cs to get versions.
Comment 2 Landon Curt Noll 2005-05-14 15:05:14 EDT
$ rpm -q kernel pcmcia-cs
kernel-2.6.9-6.37.EL
pcmcia-cs-3.2.7-3.2

Comment #13 from bug #53293 no longer fixes the problem:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=53293#c13

Under RHEL3 and prior (pre-ALSA) I had to make changes to
the old /etc/modules.conf file (see Comment #4 from bug #53293
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=53293#c4 ).
Obviously those lines no longer apply for RHEL4.  Is there some
equivalent lines tha I need to add to /etc/modprobe.conf to
get sound working under RHEL4 for the ThinkPad 770Z?
Comment 3 Pete Zaitcev 2005-05-14 15:48:19 EDT
I suggest something like this:

alias char-major-116 snd
alias snd-card-0 snd-cs4232
alias char-major-14 soundcore 
#alias sound-slot-0 snd-card-0 
#alias sound-service-0-0 snd-mixer-oss 
#alias sound-service-0-1 snd-seq-oss 
#alias sound-service-0-3 snd-pcm1-oss 
#alias sound-service-0-12 snd-pcm1-oss 
#alias synth0 opl3 
#options sound dmabuf=1 
#options snd snd_major=116 snd_cards_limit=1 snd_device_mode=0666
snd_device_gid=0 snd_device_uid=0
#options opl3 io=0x388 
#options snd-cs4232 port=0x530 mpu_port=0x330 irq=5 mpuirq=7 dma=1 dma2=0

Note that I left options to snd-cs4232 commented because it should
be PnP capable and not needing any explicit settings.

Old xmms binaries may need OSS emulation, I'm not sure how well that
works. Please try with something like aplay or mpg321 first. Once that
works, xmms can be brought into picture.
Comment 4 Pete Zaitcev 2012-01-22 21:35:20 EST
6 years without updates, closing.

Note You need to log in before you can comment on or make changes to this bug.