Bug 1576783 - Engine VM MAC address is hard-coded
Summary: Engine VM MAC address is hard-coded
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: 0.11.20
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.4
: 0.11.25
Assignee: Phillip Bailey
QA Contact: Yihui Zhao
URL:
Whiteboard:
Depends On:
Blocks: cockpit-ovirt-0.11.28
TreeView+ depends on / blocked
 
Reported: 2018-05-10 11:55 UTC by Phillip Bailey
Modified: 2018-06-26 08:35 UTC (History)
10 users (show)

Fixed In Version: cockpit-ovirt-0.11.25-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:35:53 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
cshao: testing_plan_complete?
yzhao: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91111 0 master MERGED wizard: Generate a random VM MAC address 2018-05-17 12:05:11 UTC
oVirt gerrit 91347 0 ovirt-4.2 MERGED wizard: Generate a random VM MAC address 2018-05-17 12:06:07 UTC

Description Phillip Bailey 2018-05-10 11:55:02 UTC
Description of problem:
The engine VM MAC address is hard-coded in the Cockpit wizard, but should be randomly generated.

Version-Release number of selected component (if applicable):
cockpit-ovirt-0.11.23-1

How reproducible:
100%

Steps to Reproduce:
1. Install hosted engine via the Cockpit hosted engine wizard

Actual results:
The engine VM MAC address is not randomly generated.

Expected results:
A unique, randomly generated address should be created for each run of the wizard.

Comment 1 Yihui Zhao 2018-05-30 01:24:55 UTC
Can reproduce with cockpit-ovirt-0.11.23-1.

Comment 2 Yihui Zhao 2018-05-30 01:26:19 UTC
Tested with cockpit-ovirt-0.11.25-1:

Randomly generated address was created for each run of the HE wizard.

So, change the bug's status to verified.

Comment 3 Sandro Bonazzola 2018-06-26 08:35:53 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.