Bug 1576805 - Wrong python3 dependency
Summary: Wrong python3 dependency
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-networkx
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 12:21 UTC by Antonio T. (sagitter)
Modified: 2018-11-02 20:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-02 20:22:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Antonio T. (sagitter) 2018-05-10 12:21:38 UTC
Description of problem:
python3-networkx-drawing-1.11-10.fc29 is requiring a Python2 package (python2-graphviz).

Version-Release number of selected component (if applicable):
python-networkx-1.11-10

How reproducible:
Always on fedora 28+

Actual results:
DEBUG util.py:439:    - package python3-networkx-1.11-10.fc29.noarch requires python3-networkx-drawing = 1.11-10.fc29, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides python2-graphviz needed by python3-networkx-drawing-1.11-10.fc29.noarch

Additional info:
https://src.fedoraproject.org/rpms/python-networkx/blob/master/f/python-networkx.spec#_156

Comment 1 Jerry James 2018-05-11 01:21:25 UTC
Hmmm, I'm not sure what to do about this.  There is no python3-graphviz package, which I guess means that networkx is partially broken when used with python 3.  There is a graphviz-python package, but that is python 2 only.  Suggestions on what to do are welcome.

Comment 2 Michal Jaegermann 2018-05-15 19:11:37 UTC
(In reply to Jerry James from comment #1)

>  Suggestions on what to do are welcome.

Hard to say.  The above blocks in rawhide an update of 

graphviz 
graphviz-devel                                   
graphviz-devil                                   
graphviz-gd                                      
gwenhywfar                                       
gwenhywfar-devel                                 
gwenhywfar-gui-cpp                               
gwenhywfar-gui-qt4

Adding '--allowerasing' makes it possible to proceed but that removes entirely

python3-networkx 
python3-networkx-drawing 
setools-gui

which seems to be excessive.  Such operation also replaces python2-graphviz.x86_64 with graphviz-python2 (version 2.40.1-25.fc29) and gwenhywfar-gui-gtk2.x86_64 with gwenhywfar-gui-gtk3.  The later one looks like intended.  Not sure how this should end up but maybe some "Provides/Obsoletes" could untangle that knot?

Also, at least for a time beeing, replacing in dependencies python2-graphviz with newer graphviz-python2 (no idea why the name change) likely would make things easier.

Comment 3 Jan Kurik 2018-08-14 11:06:50 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 4 Jerry James 2018-11-02 20:22:59 UTC
This was worked around for F29 and fixed properly in Rawhide, so I'm closing this bug for now.  Please reopen it if there are further issues.


Note You need to log in before you can comment on or make changes to this bug.