Bug 1576814 - GlusterFS can be improved
Summary: GlusterFS can be improved
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1193929
Blocks: 1576815 1576816
TreeView+ depends on / blocked
 
Reported: 2018-05-10 12:42 UTC by Kaleb KEITHLEY
Modified: 2019-11-22 16:09 UTC (History)
4 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1193929
: 1576815 (view as bug list)
Environment:
Last Closed: 2019-11-22 16:09:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2018-05-10 12:42:08 UTC
+++ This bug was initially created as a clone of Bug #1193929 +++

I hope this bug is never fixed.

The upstream patch process requires that each patch have an associated bug ID before it can be merged.  However, there is no requirement that the bug contain any information or receive any kind of signoff before the patch can proceed.  As a result, many of our developers have the habit of creating such "placeholder" bugs every time they want to make a change, even if it's just a random cleanup/idea and not an actual bug fix or requested/tracked feature request.  Also, any patch with the dreaded "rfc" bug ID (which would be appropriate for such changes) is unlikely to be reviewed.

This bug exists to satisfy our process requirement, without the additional negatives of clogging up our triage/tracking processes and making it appear that the code has more bugs (which would be bad) when in fact a developer had more ideas (which is generally good).

--- Additional comment from Vijay Bellur on 2016-07-27 05:30:29 EDT ---

REVIEW: http://review.gluster.org/14638 (tier: Suppress warning when tiering is disabled) posted (#2) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-27 05:31:27 EDT ---

REVIEW: http://review.gluster.org/14638 (tier: Suppress warning when tiering is disabled) posted (#3) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-27 06:40:53 EDT ---

REVIEW: http://review.gluster.org/11922 (README: improve readability and add a clickable link) posted (#5) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-27 07:12:09 EDT ---

COMMIT: http://review.gluster.org/14638 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 98280290cd4a483f72c8c4d614eb826117383e1d
Author: Prashanth Pai <ppai@redhat.com>
Date:   Mon May 30 11:56:17 2016 +0530

    tier: Suppress warning when tiering is disabled
    
    Suppress -Wunused-function compile time warnings when tiering is
    disabled with --disable-tiering.
    
    BUG: 1193929
    Change-Id: I396e03631606ce60a953ed5e124986ae2c803abd
    Signed-off-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-on: http://review.gluster.org/14638
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.org>

--- Additional comment from Vijay Bellur on 2016-07-27 07:15:19 EDT ---

COMMIT: http://review.gluster.org/11922 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit dbc8dac5c357a28aeba17894f8b02faa2af2a792
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Aug 14 11:13:54 2015 +0200

    README: improve readability and add a clickable link
    
    It is easier to have a link that can be clicked.
    
    Change-Id: Id0f75b3e68ca358c218e7f1f00769545dab0c058
    BUG: 1193929
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/11922
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

--- Additional comment from Worker Ant on 2017-04-10 06:22:26 EDT ---

REVIEW: https://review.gluster.org/16200 (glusterd: Propagate EADDRINUSE correctly to parent process) posted (#6) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-04-12 23:49:06 EDT ---

COMMIT: https://review.gluster.org/16200 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 94afe2ca98a8ed9effb05901fc89d3b7bb6d0d41
Author: Prashanth Pai <ppai@redhat.com>
Date:   Mon Dec 19 16:28:06 2016 +0530

    glusterd: Propagate EADDRINUSE correctly to parent process
    
    exit()/_exit():
    Only the least significant 8 bits i.e (err & 255) shall be available
    to the waiting parent process on calling _exit() or exit() with an
    integer exit status. If this number is negative, the parent process
    doesn't readily get what it's really looking forward to handle.
    
    For example: EADDRINUSE is 98 and if exit status code is set to -98,
    the waiting parent process shall get 158 (= -98 & 255) as exit status.
    
    BUG: 1193929
    
    Change-Id: Idc6b0f40c2332e087e584b4b40cbf0d29168c9cd
    Signed-off-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-on: https://review.gluster.org/16200
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

--- Additional comment from Worker Ant on 2017-04-27 09:05:43 EDT ---

REVIEW: https://review.gluster.org/17129 (glusterd: Fix removing pmap entry on rpc disconnect) posted (#1) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-04-27 09:07:44 EDT ---

REVIEW: https://review.gluster.org/17129 (glusterd: Fix removing pmap entry on rpc disconnect) posted (#2) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-04-28 13:15:33 EDT ---

COMMIT: https://review.gluster.org/17129 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit 081f9febeec61787ebe81850a081beda17de3047
Author: Prashanth Pai <ppai@redhat.com>
Date:   Thu Apr 27 18:26:02 2017 +0530

    glusterd: Fix removing pmap entry on rpc disconnect
    
    Problem:
    The following line of code intended to remove pmap entry for the
    connection during disconnects:
    
        pmap_registry_remove (this, 0, NULL, GF_PMAP_PORT_NONE, xprt);
    
    However, no pmap entry will have it's type set to GF_PMAP_PORT_NONE
    at any point in time. So a call to pmap_registry_search_by_xprt() in
    pmap_registry_remove() will always fail to find a match.
    
    Fix:
    Optionally ignore pmap entry's type in pmap_registry_search_by_xprt().
    
    BUG: 1193929
    Change-Id: I705f101739ab1647ff52a92820d478354407264a
    Signed-off-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-on: https://review.gluster.org/17129
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>

--- Additional comment from Worker Ant on 2017-06-30 09:20:14 EDT ---

REVIEW: https://review.gluster.org/17659 (Link against missed libraries to resolve symbols) posted (#1) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-06-30 13:59:53 EDT ---

REVIEW: https://review.gluster.org/17659 (Link against missed libraries to resolve symbols) posted (#2) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-07-03 06:58:18 EDT ---

COMMIT: https://review.gluster.org/17659 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit 97a08698058962a4ddc783008c92ee94f08740a9
Author: Prashanth Pai <ppai@redhat.com>
Date:   Fri Jun 30 15:52:53 2017 +0530

    Link against missed libraries to resolve symbols
    
    When external programs perform a dlopen("..so", RTLD_LAZY|RTLD_LOCAL)
    on some shared objects like xlators, it can fail with dlerror set to
    error string "undefined symbol <some-type>".
    
    This was observed for the following shared objects: fuse.so, quota.so,
    quotad.so, server.so, libgfrpc.so and socket.so
    
    P.S: This was found while running a go program which fetches the list
    of xlator options (volume_option_t) from xlator's shared object.
    
    BUG: 1193929
    Change-Id: I7b958409cf11fb67c2be32a3f85a96fb1260236b
    Signed-off-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-on: https://review.gluster.org/17659
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>

--- Additional comment from Worker Ant on 2017-07-12 03:38:51 EDT ---

REVIEW: https://review.gluster.org/17753 (socket: avoid calling GF_CALLOC() in init_openssl_mt()) posted (#1) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-07-13 01:58:26 EDT ---

REVIEW: https://review.gluster.org/17753 (socket: avoid calling GF_CALLOC() in init_openssl_mt()) posted (#2) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-07-13 09:50:11 EDT ---

REVIEW: https://review.gluster.org/17753 (socket: call init_openssl_mt() in init() and add cleanup) posted (#3) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-07-14 08:38:34 EDT ---

REVIEW: https://review.gluster.org/17753 (socket: call init_openssl_mt() in init() and add cleanup) posted (#4) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-07-17 13:09:09 EDT ---

COMMIT: https://review.gluster.org/17753 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit 58a15ae04e597d6ab353f00a3ee72260c0b6f802
Author: Prashanth Pai <ppai@redhat.com>
Date:   Wed Jul 12 12:59:35 2017 +0530

    socket: call init_openssl_mt() in init() and add cleanup
    
    init_openssl_mt() wasn't explicitly invoked and was run implicitly before
    dlopen() returned as it was tagged as __attribute__ ((constructor)). This
    function used to call GF_CALLOC() which wasn't available or initialized
    when socket.so is dlopen()ed by an external program. The program used to
    crash with SIGSEGV as follows:
    
    0x00007ffff5efe1ad in __gf_calloc (nmemb=41, size=40, type=158, typestr=0x7ffff63eb3d6 "gf_sock_mt_lock_array")
    at mem-pool.c:109
    0x00007ffff63e6acf in init_openssl_mt () at socket.c:4016
    0x00007ffff7de90da in call_init.part () from /lib64/ld-linux-x86-64.so.2
    0x00007ffff7de91eb in _dl_init () from /lib64/ld-linux-x86-64.so.2
    0x00007ffff7dedde1 in dl_open_worker () from /lib64/ld-linux-x86-64.so.2
    0x00007ffff7de8f84 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
    0x00007ffff7ded339 in _dl_open () from /lib64/ld-linux-x86-64.so.2
    
    This change moves call to init_openssl_mt() from being a constructor function
    to the init() function and introduces fini_openssl_mt() which cleans up
    resources (called in destructor).
    
    BUG: 1193929
    Change-Id: Iab690897ec34e24c33f6b43f8d8d9f8fd75ac607
    Signed-off-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-on: https://review.gluster.org/17753
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>

--- Additional comment from Worker Ant on 2017-07-21 06:21:47 EDT ---

REVIEW: https://review.gluster.org/17848 (rpc: prevent logging null client [Invalid argument]) posted (#1) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-07-21 06:52:37 EDT ---

REVIEW: https://review.gluster.org/17848 (rpc: prevent logging null client [Invalid argument]) posted (#2) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-07-25 02:28:59 EDT ---

REVIEW: https://review.gluster.org/17848 (rpc: prevent logging null client [Invalid argument]) posted (#3) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-07-25 08:47:11 EDT ---

COMMIT: https://review.gluster.org/17848 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit 7140858c3816c89d22d81ddfaa1d270db5dfd622
Author: Prashanth Pai <ppai@redhat.com>
Date:   Fri Jul 21 15:48:23 2017 +0530

    rpc: prevent logging null client [Invalid argument]
    
    The following log entry is observed during volume operations such
    as volume create:
    
    [2017-07-20 05:13:43.213797] E [client_t.c:321:gf_client_ref]
    (-->/usr/local/lib/libgfrpc.so.0(rpcsvc_request_create+0x1a4) [0x7f987f66cd20]
    -->/usr/local/lib/libgfrpc.so.0(rpcsvc_request_init+0xd0) [0x7f987f66ca23]
    -->/usr/local/lib/libglusterfs.so.0(gf_client_ref+0x56) [0x7f987f91cbd5] )
    0-client_t: null client [Invalid argument]
    
    Change-Id: I49ba753e8d1a828bb275b0ccb1a181706774f387
    BUG: 1193929
    Signed-off-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-on: https://review.gluster.org/17848
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Amar Tumballi <amarts@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

--- Additional comment from Worker Ant on 2017-10-17 01:56:22 EDT ---

REVIEW: https://review.gluster.org/18535 (worm/read-only: Add sentinel NULL key to options) posted (#1) for review on master by Prashanth Pai (ppai@redhat.com)

--- Additional comment from Worker Ant on 2017-10-17 07:09:59 EDT ---

COMMIT: https://review.gluster.org/18535 committed in master by Prashanth Pai (ppai@redhat.com) 
------
commit 4f3c680ed8350496e18de127064be816388dafdd
Author: Prashanth Pai <ppai@redhat.com>
Date:   Tue Oct 17 10:57:13 2017 +0530

    worm/read-only: Add sentinel NULL key to options
    
    BUG: 1193929
    Change-Id: Ibfee382362826556e2e760f9b946c83445d6a08e
    Signed-off-by: Prashanth Pai <ppai@redhat.com>

--- Additional comment from Worker Ant on 2017-12-27 02:07:44 EST ---

REVIEW: https://review.gluster.org/19056 (Use RTLD_LOCAL for symbol resolution) posted (#3) for review on master by Prashanth Pai

--- Additional comment from Worker Ant on 2017-12-27 10:50:20 EST ---

COMMIT: https://review.gluster.org/19056 committed in master by \"Prashanth Pai\" <ppai@redhat.com> with a commit message- Use RTLD_LOCAL for symbol resolution

RTLD_LOCAL is the default value for symbol visibility flag of dlopen()
in Linux and NetBSD. Using it avoids conflicts during symbol resolution.

This also allows us to detect xlators that have not been explicitly
linked with libraries that they use. This used to go unnoticed
when RTLD_GLOBAL was being used.

BUG: 1193929
Change-Id: I50db6ea14ffdee96596060c4d6bf71cd3c432f7b
Signed-off-by: Prashanth Pai <ppai@redhat.com>

--- Additional comment from Worker Ant on 2018-01-29 03:58:41 EST ---

REVIEW: https://review.gluster.org/19339 (libglusterfs: cleanup useless need_lookup) posted (#3) for review on master by Niels de Vos

--- Additional comment from Worker Ant on 2018-02-07 00:10:09 EST ---

REVIEW: https://review.gluster.org/19517 (log: Change some frequent log entries to DEBUG) posted (#1) for review on master by Prashanth Pai

--- Additional comment from Shyamsundar on 2018-03-15 07:16:50 EDT ---

This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/

--- Additional comment from Shyamsundar on 2018-03-15 07:30:22 EDT ---

Reopening, inadvertently closed.

--- Additional comment from Worker Ant on 2018-04-05 07:54:25 EDT ---

REVIEW: https://review.gluster.org/19824 (doc: Update the admin guide link) posted (#2) for review on master by Varsha Rao

--- Additional comment from Worker Ant on 2018-04-06 06:14:07 EDT ---

COMMIT: https://review.gluster.org/19824 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- doc: Update the admin guide link

Update the existing admin guide link as it is incorrect.

Change-Id: I05669192623aeac287dfa9002caa0f390ea79499
Updates: bz#1193929
Signed-off-by: Varsha Rao <varao@redhat.com>

--- Additional comment from Worker Ant on 2018-04-16 10:00:06 EDT ---

REVIEW: https://review.gluster.org/19882 (Add CLI option to print XLATORDIR) posted (#1) for review on master by Prashanth Pai

--- Additional comment from Worker Ant on 2018-04-18 04:28:10 EDT ---

COMMIT: https://review.gluster.org/19882 committed in master by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- Add CLI option to print XLATORDIR

glusterfs gets the path to xlator dir from a compile time flag named
XLATORDIR which gets passed through a -D flag to GCC. This path is
used to find and load xlator shared objects.

The XLATORDIR path isn't easily accessible to glusterd2. Glusterd2
currently uses the following command (hack) to get value of XLATORDIR:

$ strings -d `which glusterfsd` | awk '/glusterfs/*/xlator$/'

This change introduces "print-xlatordir" CLI option to expose
XLATORDIR. The option is intentionally not documented.

Updates: bz#1193929
Change-Id: Ic7247457600f11cd8d68eb3d0ad2526fdfda0b02
Signed-off-by: Prashanth Pai <ppai@redhat.com>

--- Additional comment from Worker Ant on 2018-04-19 03:28:57 EDT ---

REVIEW: https://review.gluster.org/19905 (Make glusterfsd binary print statedump & xlator dir) posted (#1) for review on master by Prashanth Pai

--- Additional comment from Worker Ant on 2018-04-19 10:25:14 EDT ---

COMMIT: https://review.gluster.org/19905 committed in master by "Prashanth Pai" <ppai@redhat.com> with a commit message- Make glusterfsd binary print statedump & xlator dir

The glusterd2 needs following options, some of which are provided by
gluster CLI today:

--print-xlatordir
--print-statedumpdir
--print-logdir

However, the CLI package need not be present on the machine running
glusterd2. This change adds the above CLI options to glusterfsd binary
which glusterd2 depends on.

Reverts 9a1ae47c8d60836ae0628a04a153f28c1085c0e8

Related changes:
https://review.gluster.org/#/c/19882/
https://github.com/gluster/glusterd2/pull/663

Updates: bz#1193929
Change-Id: I18c123b0d3350d2bd4f2400783e3b94e402a4e29
Signed-off-by: Prashanth Pai <ppai@redhat.com>

--- Additional comment from Worker Ant on 2018-04-23 06:01:06 EDT ---

REVIEW: https://review.gluster.org/19923 (build: Disallow unresolved symbol references) posted (#1) for review on master by Prashanth Pai

--- Additional comment from Worker Ant on 2018-05-04 05:35:47 EDT ---

REVIEW: https://review.gluster.org/19955 (mount,fuse: make fuse dumping available as mount option) posted (#2) for review on master by Csaba Henk

--- Additional comment from Worker Ant on 2018-05-04 13:43:03 EDT ---

COMMIT: https://review.gluster.org/19955 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- mount,fuse: make fuse dumping available as mount option

Updates: bz#1193929
Change-Id: I4dd4d0e607f89650ebb74b893b911b554472826d
Signed-off-by: Csaba Henk <csaba@redhat.com>

--- Additional comment from Worker Ant on 2018-05-08 13:55:55 EDT ---

REVIEW: https://review.gluster.org/19976 (features/cloudsync: Remove multiple definition in Makefile.am) posted (#2) for review on master by Anoop C S

--- Additional comment from Worker Ant on 2018-05-09 07:20:41 EDT ---

REVIEW: https://review.gluster.org/19994 (core: FreeBSD has pthread_set_name_np() (versus pthread_setname_np())) posted (#1) for review on master by Kaleb KEITHLEY

--- Additional comment from Worker Ant on 2018-05-09 13:37:10 EDT ---

COMMIT: https://review.gluster.org/19994 committed in master by "Kaleb KEITHLEY" <kkeithle@redhat.com> with a commit message- core: FreeBSD has pthread_set_name_np() (versus pthread_setname_np())

And has had it since at least FreeBSD 9.0

Reported-by: Roman Serbski <mefystofel@gmail.com>

Change-Id: I52cfde7f2f7a82d0e66465ac392ed7e201e1653b
updates: bz#1193929
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>

--- Additional comment from Worker Ant on 2018-05-10 07:37:37 EDT ---

COMMIT: https://review.gluster.org/19976 committed in master by "Kaleb KEITHLEY" <kkeithle@redhat.com> with a commit message- features/cloudsync: Remove multiple definition in Makefile.am

CLOUDSYNC_SRC is defined twice in the same Makefile.am which generates
the following warning:

xlators/features/cloudsync/src/Makefile.am:9: warning: CLOUDSYNC_SRC multiply defined in condition TRUE ...
xlators/features/cloudsync/src/Makefile.am:5: ... 'CLOUDSYNC_SRC' previously defined here

Therefore removing the duplicate definition.

Change-Id: I00c3e2f3d64ad45e4080c2c82766516cd3e2bf63
fixes: bz#1193929
BUG: 1193929
Signed-off-by: Anoop C S <anoopcs@redhat.com>

--- Additional comment from Worker Ant on 2018-05-10 07:49:17 EDT ---

REVIEW: https://review.gluster.org/20002 (core: FreeBSD has pthread_set_name_np() (versus pthread_setname_np())) posted (#1) for review on release-4.1 by Kaleb KEITHLEY

--- Additional comment from Worker Ant on 2018-05-10 07:50:16 EDT ---

REVIEW: https://review.gluster.org/20003 (core: FreeBSD has pthread_set_name_np() (versus pthread_setname_np())) posted (#1) for review on release-4.0 by Kaleb KEITHLEY

--- Additional comment from Worker Ant on 2018-05-10 07:51:11 EDT ---

REVIEW: https://review.gluster.org/20004 (core: FreeBSD has pthread_set_name_np() (versus pthread_setname_np())) posted (#1) for review on release-3.12 by Kaleb KEITHLEY

Comment 1 Worker Ant 2018-05-10 12:48:21 UTC
REVIEW: https://review.gluster.org/20002 (core: FreeBSD has pthread_set_name_np() (versus pthread_setname_np())) posted (#2) for review on release-4.1 by Kaleb KEITHLEY

Comment 2 Worker Ant 2018-05-10 17:24:50 UTC
COMMIT: https://review.gluster.org/20002 committed in release-4.1 by "Kaleb KEITHLEY" <kkeithle@redhat.com> with a commit message- core: FreeBSD has pthread_set_name_np() (versus pthread_setname_np())

And has had it since at least FreeBSD 9.0

Reported-by: Roman Serbski <mefystofel@gmail.com>

Change-Id: I52cfde7f2f7a82d0e66465ac392ed7e201e1653b
updates: bz#1576814
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:06:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 4 Shyamsundar 2019-02-22 13:15:43 UTC
Keeping this bug open, as changes that do not need a specific bug but are improvements are backported, and 4.1 release lifecycle is not over yet.


Note You need to log in before you can comment on or make changes to this bug.