Bug 1576828 - [RFE] Generic object details displayed from a service do not include associations of that generic object
Summary: [RFE] Generic object details displayed from a service do not include associat...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.11.z
Assignee: Harpreet Kataria
QA Contact: Shveta
URL:
Whiteboard:
: 1595179 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 13:20 UTC by Peter McGowan
Modified: 2019-12-18 14:33 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-18 14:33:32 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Generic object viewed from service WebUI page (139.23 KB, image/png)
2018-05-10 13:20 UTC, Peter McGowan
no flags Details
Generic object viewed from automate WebUI page (171.86 KB, image/png)
2018-05-10 13:20 UTC, Peter McGowan
no flags Details

Description Peter McGowan 2018-05-10 13:20:26 UTC
Created attachment 1434356 [details]
Generic object viewed from service WebUI page

Description of problem:
https://bugzilla.redhat.com/show_bug.cgi?id=1553309 fixed an issue whereby if a service contains a generic object, the details of the generic object were inaccessible other than by navigating through Automation -> Automate -> Generic Objects.

The fix for that BZ has made the properties, attributes and methods of the generic object visible from the service, but not the associations of the generic object. The associations should be visible as well (and clickable to navigate through).

Version-Release number of selected component (if applicable):
5.9.2.4

How reproducible:
Every time

Steps to Reproduce:
1. Create a generic object definition that includes an association to another object type
2. Create a service that contains a generic object instance of the above generic object definition, including an association to another object.
2. View the service in the WebUI "My Services'. Navigate to the generic object

Actual results:
Generic object details except for associations are visible

Expected results:
Generic object details including associations should be visible

Additional info:
The attached screenshots show the same generic object, viewed from the services page and the automation page. The associations of the object are only visible in the screenshot from the automation page

Comment 2 Peter McGowan 2018-05-10 13:20:58 UTC
Created attachment 1434357 [details]
Generic object viewed from automate WebUI page

Comment 3 Tina Fitzgerald 2018-05-11 14:38:45 UTC
Hi Dan,

Sending this ticket your way.

I spoke to Lucy and she said the associations to the generic objects exist. 

Let me know if you have any questions.

Thanks,
Tina

Comment 4 Shveta 2018-05-11 18:42:52 UTC
Checked in 5.9.2.4.20180501195858_35dc609.
Generic object details only show attribute and Method .
Associations are not displayed .

Comment 8 Chris Pelland 2018-07-03 14:20:01 UTC
*** Bug 1595179 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.