Bug 1576833 - while upgrading to Fedora 28: dnf is quite confused about availability of packages
Summary: while upgrading to Fedora 28: dnf is quite confused about availability of pac...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 13:46 UTC by udo
Modified: 2018-05-24 07:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-24 07:21:08 UTC
Type: Bug


Attachments (Terms of Use)

Description udo 2018-05-10 13:46:36 UTC
Description of problem:
While upgrading to Fedora 28: dnf is quite confused about availability of packages. It simply cannot find some of them or similar.

Version-Release number of selected component (if applicable):
dnf-2.7.5-2.fc26.noarch

How reproducible:
Run Fedora 26.
Because updating once a year is often enough one decides round about now to look into upgrading to Fedora 28.
So one runs `dnf system-upgrade download  --releasever=28`
One is confused by the seemingly mandatory check that is of no real issue in a proper upgrade system: `extra` rpms are not known and thus should not count in dependency-hell calculations.
Furthermore the issues below pop up which mostly mention standard items of the Fedora installations.
How can one find the root cause of not finding these essential packages?


Actual results:
See below

Expected results:
Smooth upgrade process.

Additional info:
# dnf system-upgrade download  --releasever=28
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Fedora 28 - x86_64 - Updates                   2.5 MB/s | 6.0 MB     00:02    
Fedora 28 - x86_64                             5.8 MB/s |  60 MB     00:10    
google-chrome                                   85 kB/s | 3.8 kB     00:00    
MEGAsync                                       104 kB/s |  12 kB     00:00    
RPM Fusion for Fedora 28 - Free - Updates      600 kB/s |  34 kB     00:00    
RPM Fusion for Fedora 28 - Free                4.4 MB/s | 754 kB     00:00    
RPM Fusion for Fedora 28 - Nonfree - Updates    73 kB/s | 3.6 kB     00:00    
RPM Fusion for Fedora 28 - Nonfree             1.7 MB/s | 208 kB     00:00    
skype (stable)                                  54 kB/s | 4.2 kB     00:00    
Last metadata expiration check: 0:00:00 ago on Thu 10 May 2018 03:37:42 PM CEST.
Error: 
 Problem 1: problem with installed package grubby-8.40-4.fc26.x86_64
  - grubby-8.40-4.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides grub2-tools needed by grubby-8.40-11.fc28.x86_64
 Problem 2: problem with installed package control-center-1:3.24.4-1.fc26.x86_64
  - control-center-1:3.24.4-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 3: package ICAClient-13.4.0.10109380-0.x86_64 requires webkitgtk, but none of the providers can be installed
  - webkitgtk-2.4.11-5.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package ICAClient-13.4.0.10109380-0.x86_64
 Problem 4: package ffmpeg-compat-0.6.7-10.fc26.x86_64 requires libx264.so.148()(64bit), but none of the providers can be installed
  - x264-libs-0.148-20.20170519gitd32d7bf.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package ffmpeg-compat-0.6.7-10.fc26.x86_64
 Problem 5: package gnome-mplayer-minimal-1.0.9-3.20150203svn2476.fc22.x86_64 requires libgmlib.so.1()(64bit), but none of the providers can be installed
  - gmtk-1.0.9-2.fc22.x86_64 does not belong to a distupgrade repository
  - problem with installed package gnome-mplayer-minimal-1.0.9-3.20150203svn2476.fc22.x86_64
 Problem 6: package gnome-mplayer-nautilus-1.0.9-3.20150203svn2476.fc22.x86_64 requires gnome-mplayer(x86-64) = 1.0.9-3.20150203svn2476.fc22, but none of the providers can be installed
  - gnome-mplayer-1.0.9-3.20150203svn2476.fc22.x86_64 does not belong to a distupgrade repository
  - problem with installed package gnome-mplayer-nautilus-1.0.9-3.20150203svn2476.fc22.x86_64
 Problem 7: package gnome-online-accounts-3.24.4-3.fc26.x86_64 requires webkitgtk4(x86-64) >= 2.7.2, but none of the providers can be installed
  - webkitgtk4-2.20.1-1.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package gnome-online-accounts-3.24.4-3.fc26.x86_64
 Problem 8: package xchat-1:2.8.8-34.fc26.x86_64 requires libperl.so.5.24()(64bit), but none of the providers can be installed
  - perl-libs-4:5.24.4-397.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package xchat-1:2.8.8-34.fc26.x86_64
 Problem 9: package gdm-1:3.28.1-1.fc28.x86_64 requires gnome-shell, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - problem with installed package gdm-1:3.24.3-1.fc26.x86_64
  - package control-center-1:3.24.4-1.fc26.x86_64 requires control-center-filesystem = 1:3.24.4-1.fc26, but none of the providers can be installed
  - gnome-shell-3.24.3-2.fc26.x86_64 does not belong to a distupgrade repository
  - gdm-1:3.24.3-1.fc26.x86_64 does not belong to a distupgrade repository
  - control-center-filesystem-1:3.24.4-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 10: package gnome-shell-extension-common-3.28.1-1.fc28.noarch requires gnome-shell >= 3.28.1, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - problem with installed package gnome-shell-extension-common-3.24.3-1.fc26.noarch
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgnome-desktop-3.so.12()(64bit), but none of the providers can be installed
  - gnome-shell-extension-common-3.24.3-1.fc26.noarch does not belong to a distupgrade repository
  - gnome-desktop3-3.24.2-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 11: package gdm-1:3.28.1-1.fc28.x86_64 requires gnome-shell, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - problem with installed package pulseaudio-gdm-hooks-11.1-7.fc26.x86_64
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgtop-2.0.so.10()(64bit), but none of the providers can be installed
  - package gnome-shell-3.24.3-2.fc26.x86_64 requires libedataserver-1.2.so.22()(64bit), but none of the providers can be installed
  - pulseaudio-gdm-hooks-11.1-7.fc26.x86_64 does not belong to a distupgrade repository
  - libgtop2-2.36.0-1.fc26.x86_64 does not belong to a distupgrade repository
  - evolution-data-server-3.24.7-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 12: package gnome-online-accounts-3.24.4-3.fc26.x86_64 requires webkitgtk4(x86-64) >= 2.7.2, but none of the providers can be installed
  - package libgdata-0.17.9-2.fc28.x86_64 requires libgoa-1.0.so.0()(64bit), but none of the providers can be installed
  - package webkitgtk4-2.20.1-1.fc26.x86_64 requires webkitgtk4-jsc(x86-64) = 2.20.1-1.fc26, but none of the providers can be installed
  - problem with installed package libgdata-0.17.8-1.fc26.x86_64
  - webkitgtk4-jsc-2.20.1-1.fc26.x86_64 does not belong to a distupgrade repository
  - libgdata-0.17.8-1.fc26.x86_64 does not belong to a distupgrade repository
 Problem 13: package webkitgtk4-2.20.1-1.fc26.x86_64 requires webkitgtk4-jsc(x86-64) = 2.20.1-1.fc26, but none of the providers can be installed
  - package gnome-online-accounts-3.24.4-3.fc26.x86_64 requires webkitgtk4(x86-64) >= 2.7.2, but none of the providers can be installed
  - package webkit2gtk3-jsc-2.20.1-1.fc28.x86_64 obsoletes webkitgtk4-jsc < 2.20.1-1.fc28 provided by webkitgtk4-jsc-2.20.1-1.fc26.x86_64
  - package evolution-data-server-3.28.1-2.fc28.x86_64 requires libgoa-1.0.so.0()(64bit), but none of the providers can be installed
  - package webkit2gtk3-plugin-process-gtk2-2.20.1-1.fc28.x86_64 requires webkit2gtk3-jsc(x86-64) = 2.20.1-1.fc28, but none of the providers can be installed
  - package ekiga-4.0.1-40.fc28.x86_64 requires evolution-data-server, but none of the providers can be installed
  - problem with installed package webkitgtk4-plugin-process-gtk2-2.20.1-1.fc26.x86_64
  - package evolution-data-server-3.24.7-1.fc26.x86_64 requires libgweather-3.so.6()(64bit), but none of the providers can be installed
  - problem with installed package ekiga-4.0.1-33.fc26.x86_64
  - webkitgtk4-plugin-process-gtk2-2.20.1-1.fc26.x86_64 does not belong to a distupgrade repository
  - libgweather-3.24.1-1.fc26.x86_64 does not belong to a distupgrade repository
  - ekiga-4.0.1-33.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides libgoa-1.0.so.0 needed by evolution-data-server-3.28.1-2.fc28.i686
 Problem 14: package gnome-shell-extension-common-3.28.1-1.fc28.noarch requires gnome-shell >= 3.28.1, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgnome-desktop-3.so.12()(64bit), but none of the providers can be installed
  - cannot install both gnome-desktop3-3.28.1-1.fc28.x86_64 and gnome-desktop3-3.24.2-1.fc26.x86_64
  - package gnome-shell-extension-alternate-tab-3.28.1-1.fc28.noarch requires gnome-shell-extension-common = 3.28.1-1.fc28, but none of the providers can be installed
  - package cheese-2:3.28.0-1.fc28.x86_64 requires libgnome-desktop-3.so.17()(64bit), but none of the providers can be installed
  - problem with installed package gnome-shell-extension-alternate-tab-3.24.3-1.fc26.noarch
  - problem with installed package cheese-2:3.24.0-1.fc26.x86_64
  - gnome-shell-extension-alternate-tab-3.24.3-1.fc26.noarch does not belong to a distupgrade repository
  - cheese-2:3.24.0-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 15: package gnome-shell-extension-common-3.28.1-1.fc28.noarch requires gnome-shell >= 3.28.1, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgnome-desktop-3.so.12()(64bit), but none of the providers can be installed
  - cannot install both gnome-desktop3-3.28.1-1.fc28.x86_64 and gnome-desktop3-3.24.2-1.fc26.x86_64
  - package gnome-shell-extension-apps-menu-3.28.1-1.fc28.noarch requires gnome-shell-extension-common = 3.28.1-1.fc28, but none of the providers can be installed
  - package cheese-libs-2:3.28.0-1.fc28.x86_64 requires libgnome-desktop-3.so.17()(64bit), but none of the providers can be installed
  - problem with installed package gnome-shell-extension-apps-menu-3.24.3-1.fc26.noarch
  - problem with installed package cheese-libs-2:3.24.0-1.fc26.x86_64
  - gnome-shell-extension-apps-menu-3.24.3-1.fc26.noarch does not belong to a distupgrade repository
  - cheese-libs-2:3.24.0-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 16: package gnome-shell-extension-common-3.28.1-1.fc28.noarch requires gnome-shell >= 3.28.1, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgnome-desktop-3.so.12()(64bit), but none of the providers can be installed
  - cannot install both gnome-desktop3-3.28.1-1.fc28.x86_64 and gnome-desktop3-3.24.2-1.fc26.x86_64
  - package gnome-shell-extension-auto-move-windows-3.28.1-1.fc28.noarch requires gnome-shell-extension-common = 3.28.1-1.fc28, but none of the providers can be installed
  - package eog-3.28.1-2.fc28.x86_64 requires libgnome-desktop-3.so.17()(64bit), but none of the providers can be installed
  - problem with installed package gnome-shell-extension-auto-move-windows-3.24.3-1.fc26.noarch
  - problem with installed package eog-3.24.1-1.fc26.x86_64
  - gnome-shell-extension-auto-move-windows-3.24.3-1.fc26.noarch does not belong to a distupgrade repository
  - eog-3.24.1-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 17: package gnome-shell-extension-common-3.28.1-1.fc28.noarch requires gnome-shell >= 3.28.1, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgnome-desktop-3.so.12()(64bit), but none of the providers can be installed
  - cannot install both gnome-desktop3-3.28.1-1.fc28.x86_64 and gnome-desktop3-3.24.2-1.fc26.x86_64
  - package gnome-shell-extension-launch-new-instance-3.28.1-1.fc28.noarch requires gnome-shell-extension-common = 3.28.1-1.fc28, but none of the providers can be installed
  - package evince-3.28.2-1.fc28.x86_64 requires libgnome-desktop-3.so.17()(64bit), but none of the providers can be installed
  - problem with installed package gnome-shell-extension-launch-new-instance-3.24.3-1.fc26.noarch
  - problem with installed package evince-3.24.2-2.fc26.x86_64
  - gnome-shell-extension-launch-new-instance-3.24.3-1.fc26.noarch does not belong to a distupgrade repository
  - evince-3.24.2-2.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 18: package gnome-shell-extension-common-3.28.1-1.fc28.noarch requires gnome-shell >= 3.28.1, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgnome-desktop-3.so.12()(64bit), but none of the providers can be installed
  - cannot install both gnome-desktop3-3.28.1-1.fc28.x86_64 and gnome-desktop3-3.24.2-1.fc26.x86_64
  - package gnome-shell-extension-places-menu-3.28.1-1.fc28.noarch requires gnome-shell-extension-common = 3.28.1-1.fc28, but none of the providers can be installed
  - package gnome-screensaver-3.6.1-20.fc28.x86_64 requires libgnome-desktop-3.so.17()(64bit), but none of the providers can be installed
  - problem with installed package gnome-shell-extension-places-menu-3.24.3-1.fc26.noarch
  - problem with installed package gnome-screensaver-3.6.1-16.fc26.x86_64
  - gnome-shell-extension-places-menu-3.24.3-1.fc26.noarch does not belong to a distupgrade repository
  - gnome-screensaver-3.6.1-16.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 19: package gnome-shell-extension-common-3.28.1-1.fc28.noarch requires gnome-shell >= 3.28.1, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgnome-desktop-3.so.12()(64bit), but none of the providers can be installed
  - cannot install both gnome-desktop3-3.28.1-1.fc28.x86_64 and gnome-desktop3-3.24.2-1.fc26.x86_64
  - package gnome-shell-extension-user-theme-3.28.1-1.fc28.noarch requires gnome-shell-extension-common = 3.28.1-1.fc28, but none of the providers can be installed
  - package gnome-session-3.28.1-1.fc28.x86_64 requires libgnome-desktop-3.so.17()(64bit), but none of the providers can be installed
  - problem with installed package gnome-shell-extension-user-theme-3.24.3-1.fc26.noarch
  - problem with installed package gnome-session-3.24.2-1.fc26.x86_64
  - gnome-shell-extension-user-theme-3.24.3-1.fc26.noarch does not belong to a distupgrade repository
  - gnome-session-3.24.2-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 20: package gnome-shell-extension-common-3.28.1-1.fc28.noarch requires gnome-shell >= 3.28.1, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgnome-desktop-3.so.12()(64bit), but none of the providers can be installed
  - cannot install both gnome-desktop3-3.28.1-1.fc28.x86_64 and gnome-desktop3-3.24.2-1.fc26.x86_64
  - package gnome-shell-extension-window-list-3.28.1-1.fc28.noarch requires gnome-shell-extension-common = 3.28.1-1.fc28, but none of the providers can be installed
  - package gnome-settings-daemon-3.28.1-1.fc28.x86_64 requires libgnome-desktop-3.so.17()(64bit), but none of the providers can be installed
  - problem with installed package gnome-shell-extension-window-list-3.24.3-1.fc26.noarch
  - problem with installed package gnome-settings-daemon-3.24.4-1.fc26.x86_64
  - gnome-shell-extension-window-list-3.24.3-1.fc26.noarch does not belong to a distupgrade repository
  - gnome-settings-daemon-3.24.4-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 21: package gnome-shell-extension-common-3.28.1-1.fc28.noarch requires gnome-shell >= 3.28.1, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgtop-2.0.so.10()(64bit), but none of the providers can be installed
  - cannot install both libgtop2-2.38.0-3.fc28.x86_64 and libgtop2-2.36.0-1.fc26.x86_64
  - package gnome-shell-extension-alternate-tab-3.28.1-1.fc28.noarch requires gnome-shell-extension-common = 3.28.1-1.fc28, but none of the providers can be installed
  - package gnome-system-monitor-3.28.1-1.fc28.x86_64 requires libgtop-2.0.so.11()(64bit), but none of the providers can be installed
  - package gnome-classic-session-3.28.1-1.fc28.noarch requires gnome-shell-extension-alternate-tab = 3.28.1-1.fc28, but none of the providers can be installed
  - problem with installed package gnome-system-monitor-3.24.0-1.fc26.x86_64
  - problem with installed package gnome-classic-session-3.24.3-1.fc26.noarch
  - gnome-system-monitor-3.24.0-1.fc26.x86_64 does not belong to a distupgrade repository
  - gnome-classic-session-3.24.3-1.fc26.noarch does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 22: package gnome-tweaks-3.28.1-1.fc28.noarch requires gnome-shell >= 3.24, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgtop-2.0.so.10()(64bit), but none of the providers can be installed
  - cannot install both libgtop2-2.38.0-3.fc28.x86_64 and libgtop2-2.36.0-1.fc26.x86_64
  - package libgtop2-devel-2.38.0-3.fc28.x86_64 requires libgtop-2.0.so.11()(64bit), but none of the providers can be installed
  - package gnome-shell-3.24.3-2.fc26.x86_64 requires libmutter-0.so.0()(64bit), but none of the providers can be installed
  - problem with installed package libgtop2-devel-2.36.0-1.fc26.x86_64
  - problem with installed package gnome-tweak-tool-3.24.1-2.fc26.noarch
  - mutter-3.24.4-3.fc26.x86_64 does not belong to a distupgrade repository
  - libgtop2-devel-2.36.0-1.fc26.x86_64 does not belong to a distupgrade repository
  - gnome-tweak-tool-3.24.1-2.fc26.noarch does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
 Problem 23: problem with installed package gnome-shell-3.24.3-2.fc26.x86_64
  - package gnome-shell-3.24.3-2.fc26.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-3.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package gnome-shell-3.28.1-2.fc28.x86_64 requires control-center, but none of the providers can be installed
  - package control-center-1:3.24.4-1.fc26.x86_64 requires libgtop-2.0.so.10()(64bit), but none of the providers can be installed
  - cannot install both libgtop2-2.38.0-3.fc28.x86_64 and libgtop2-2.36.0-1.fc26.x86_64
  - package metacity-3.28.0-1.fc28.x86_64 requires libgtop-2.0.so.11()(64bit), but none of the providers can be installed
  - problem with installed package metacity-3.24.1-1.fc26.x86_64
  - metacity-3.24.1-1.fc26.x86_64 does not belong to a distupgrade repository
  - nothing provides gnome-online-accounts(x86-64) >= 3.25.3 needed by gnome-control-center-3.28.1-2.fc28.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Comment 1 udo 2018-05-10 13:58:10 UTC
After removing some excludes from dnf.conf the situation changes a bit.
Now the list is down to the list below.
Why are we forced to run `dnf --refresh upgrade`?
Why is this blocking the system upgrade? These are all not so essential packages which ARE available in the repos so why does dnf complain?
This issue was not present when we upgraded to Fedora 26 and we could fix missing dependencies after the system was upgraded.

# dnf system-upgrade download  --releasever=28
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Last metadata expiration check: 0:00:00 ago on Thu 10 May 2018 03:54:47 PM CEST.
Error: 
 Problem 1: package ICAClient-13.4.0.10109380-0.x86_64 requires webkitgtk, but none of the providers can be installed
  - webkitgtk-2.4.11-5.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package ICAClient-13.4.0.10109380-0.x86_64
 Problem 2: package ffmpeg-compat-0.6.7-10.fc26.x86_64 requires libx264.so.148()(64bit), but none of the providers can be installed
  - x264-libs-0.148-20.20170519gitd32d7bf.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package ffmpeg-compat-0.6.7-10.fc26.x86_64
 Problem 3: package gnome-mplayer-minimal-1.0.9-3.20150203svn2476.fc22.x86_64 requires libgmlib.so.1()(64bit), but none of the providers can be installed
  - gmtk-1.0.9-2.fc22.x86_64 does not belong to a distupgrade repository
  - problem with installed package gnome-mplayer-minimal-1.0.9-3.20150203svn2476.fc22.x86_64
 Problem 4: package gnome-mplayer-nautilus-1.0.9-3.20150203svn2476.fc22.x86_64 requires gnome-mplayer(x86-64) = 1.0.9-3.20150203svn2476.fc22, but none of the providers can be installed
  - gnome-mplayer-1.0.9-3.20150203svn2476.fc22.x86_64 does not belong to a distupgrade repository
  - problem with installed package gnome-mplayer-nautilus-1.0.9-3.20150203svn2476.fc22.x86_64
 Problem 5: package xchat-1:2.8.8-34.fc26.x86_64 requires libperl.so.5.24()(64bit), but none of the providers can be installed
  - perl-libs-4:5.24.4-397.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package xchat-1:2.8.8-34.fc26.x86_64

Comment 2 udo 2018-05-10 14:37:15 UTC
To be clear:
xchat for fc28 is available in the repos, so is a compatible perl-libs.
so why would I have to uninstall this program now? (and lose settings, etc depending on how this is handled)
The other `issues` should be bypassable and not block a system upgrade.

Comment 3 udo 2018-05-14 12:58:55 UTC
I had to make progress due to limited time.
I uninstalled whatever was needed (after removing the exclude lines from dnf.conf).
Then download of the rpms proceeded.

Comment 4 Jaroslav Mracek 2018-05-24 07:21:08 UTC
According to your last comment, the problem was related to set exclude in dnf.conf. Therefore the solver was unable to use excluded packages as dependencies. In DNF 3.0 the report will provide information that there is no provide due to disablement of packages. Therefore I believe that the issue was solved. Please if the problem is somewhere else, don't hesitate to reopen the bug report.


Note You need to log in before you can comment on or make changes to this bug.