Bug 1576842 - cloudsync: make plugins configurable
Summary: cloudsync: make plugins configurable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1581554
TreeView+ depends on / blocked
 
Reported: 2018-05-10 14:01 UTC by Susant Kumar Palai
Modified: 2018-10-23 15:08 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1581554 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:08:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Susant Kumar Palai 2018-05-10 14:01:55 UTC
Description of problem:

Currently, the plugins are not configurable.

Expected results:

Plugins should be configurable.

Comment 1 Worker Ant 2018-05-10 14:04:19 UTC
REVIEW: https://review.gluster.org/20000 (features/cloudsync: Make plugins configurable) posted (#3) for review on master by Susant Palai

Comment 2 Worker Ant 2018-05-22 07:49:07 UTC
COMMIT: https://review.gluster.org/20000 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- features/cloudsync: Make plugins configurable

This patch brings the configuration option for plugins.

For new plugins, an entry has to be created in to cs_plugin structure e.g.
struct cs_plugin plugins[] = {
        {
          .name = "amazons3",
          .library = "libamazons3.so",
          .description = "amazon s3 store."
        },

        {.name = NULL},
};

Library field describes the name of the shared library for the plugin.

To configure plugin type "feature.cloudsync-storetype" option need
to be set to the remote-store type. e.g.

gluster volume set VOLNAME cloudsync-storetype amazons3. This should be same
as the ".name" field in cs_plugin structure.

cs_init will pick this up in run time to load the plugin.

Change-Id: I2cec10b206f71ac4e71d472631a3a5badf278b59
fixes: bz#1576842
Signed-off-by: Susant Palai <spalai@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:08:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.