Bug 1576881 - [RFE] Add PartnerRhcc Registry Adapter
Summary: [RFE] Add PartnerRhcc Registry Adapter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.10.0
Assignee: Dylan Murray
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 15:35 UTC by Dylan Murray
Modified: 2018-07-30 19:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Add type: partner_rhcc registry adapter which works with https://regsitry.connect.redhat.com
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:17 UTC

Description Dylan Murray 2018-05-10 15:35:02 UTC
Description of problem:
In 3.9 if a user wanted to use `type: openshift` registry adapter, they must also include a list of images that they want to bootstrap. This is because there was no implementation of the catalog API which allows us to discover APB images. We should attempt to grab a list of images off /v2/_catalog if `images` is not populated in the config.

Version-Release number of selected component (if applicable):
3.9.0

How reproducible:
100%

Steps to Reproduce:
1. Remove `images` from registry config
2. Set URL to https://registry.connect.redhat.com

Actual results:
Bootstrap fails to find any images

Expected results:
Bootstrap finds rocketchat/rocketchat-apb

Additional info:

Comment 2 Dylan Murray 2018-05-16 12:13:19 UTC
Due to some confusion around the different registries... we have instead added a new registry adapter which is type: partner_rhcc which works with https://registry.connect.redhat.com.


This is because `openshift` registry still doesn't support discovery but https://registry.connect.redhat.com using a proxy does support discovery. To avoid confusion we will keep these as different adapters.

Comment 5 David Zager 2018-05-24 20:18:24 UTC
Once https://github.com/openshift/ansible-service-broker/pull/968 is merged, the next release of the broker will have this fix.

Comment 9 errata-xmlrpc 2018-07-30 19:14:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.