Bug 1576914 - Live merge failed with VolumeImageHasChildren error
Summary: Live merge failed with VolumeImageHasChildren error
Keywords:
Status: CLOSED DUPLICATE of bug 1527861
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.20.23
Hardware: x86_64
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 17:04 UTC by Elad
Modified: 2018-05-10 17:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 17:23:28 UTC
oVirt Team: Storage


Attachments (Terms of Use)
logs (3.09 MB, application/x-gzip)
2018-05-10 17:04 UTC, Elad
no flags Details

Description Elad 2018-05-10 17:04:00 UTC
Created attachment 1434478 [details]
logs

Description of problem:
After a relatively complexed scenario, live merge failed once with VolumeImageHasChildren

Version-Release number of selected component (if applicable):
vdsm-4.20.27.1-1.el7ev.x86_64
qemu-img-rhev-2.10.0-21.el7_5.2.x86_64
sanlock-3.6.0-1.el7.x86_64
libvirt-3.9.0-14.el7_5.4.x86_64
ovirt-engine-4.2.3.5-0.1.el7.noarch

How reproducible:
Once

Steps to Reproduce:
1. Create VM as thin from a template that has 1 disk attached (All disks reside on Gluster domain)
2. Create and attach 4 disks to the VM
3. Create 3 snapshots (with all disks) - snapshots 1,2,3
4. Start VM
5. Delete snapshot 1

Actual results:

Live merge fails:

2018-05-09 01:28:25,544+0300 ERROR (tasks/1) [storage.TaskManager.Task] (Task='e88ed055-a4f2-4845-bebd-5e33223899fc') Unexpected error (task:875)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/storage/task.py", line 882, in _run
    return fn(*args, **kargs)
  File "/usr/lib/python2.7/site-packages/vdsm/storage/task.py", line 336, in run
    return self.cmd(*self.argslist, **self.argsdict)
  File "/usr/lib/python2.7/site-packages/vdsm/storage/securable.py", line 79, in wrapper
    return method(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/vdsm/storage/sp.py", line 1970, in deleteVolume
    vol.delete(postZero=postZero, force=force, discard=discard)
  File "/usr/lib/python2.7/site-packages/vdsm/storage/fileVolume.py", line 502, in delete
    self.validateDelete()
  File "/usr/lib/python2.7/site-packages/vdsm/storage/volume.py", line 1270, in validateDelete
    self._manifest.validateDelete()
  File "/usr/lib/python2.7/site-packages/vdsm/storage/volume.py", line 524, in validateDelete
    raise se.VolumeImageHasChildren(self)
VolumeImageHasChildren: Cannot delete volume which has children (non-ethical): [u'sdUUID: fa2fce36-621c-44a8-8c2f-1b9e6aae68b1', 'imgUUID: 40b9e763-a3ce-4a29-85ad-7aae024200bb', 'volUUID: b57af0a3-5fd7-4a85-bd62-a5261bdd2f24']

Expected results:
Live merge should succeed

Additional info:

Comment 1 Elad 2018-05-10 17:23:28 UTC

*** This bug has been marked as a duplicate of bug 1527861 ***


Note You need to log in before you can comment on or make changes to this bug.