Bug 1576915 - Failed to upgrade RHVH to redhat-virtualization-host-4.1-20180426.0 from 4.1-20180410.1
Summary: Failed to upgrade RHVH to redhat-virtualization-host-4.1-20180426.0 from 4.1-...
Keywords:
Status: CLOSED DUPLICATE of bug 1575922
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: imgbased
Version: 4.1.11
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Ryan Barry
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 17:06 UTC by Koutuk Shukla
Modified: 2019-05-16 13:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 17:44:20 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3440281 0 None None None 2018-05-11 01:40:39 UTC

Description Koutuk Shukla 2018-05-10 17:06:30 UTC
Description of problem:

Upgrade from from redhat-virtualization-host-image-update-4.1-20180410.1.el7_5.noarch to redhat-virtualization-host-image-update-4.1-20180426.0.el7_5.noarch fails.


Version-Release number of selected component (if applicable):
RHV 4.1.11
RHVH redhat-virtualization-host-image-update-4.1-20180410.1.el7_5.noarch to

How reproducible: 
100%

Steps to Reproduce:
1.Perform RHVH upgrade to redhat-virtualization-host-4.1-20180426.0 from 4.1-20180410.1

Actual results:
Upgrade fails

Expected results:
Upgrade should complete successfully

Additional info:

Comment 2 Ryan Barry 2018-05-10 17:44:20 UTC
This is fixed in 4.2 GA

As an (untested!) workaround, they can try:

cp -rpv /etc/redhat-insights-client /etc/insights-client

Prior to updating

*** This bug has been marked as a duplicate of bug 1575922 ***

Comment 3 Ryan Barry 2018-05-11 03:50:58 UTC
I confirmed this workaround

Note that "mkdir /etc/insights-client" must be performed beforehand

Comment 14 Franta Kust 2019-05-16 13:09:18 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.