Bug 1576920 - [DOCS] Need instructions to create a cluster role
Summary: [DOCS] Need instructions to create a cluster role
Keywords:
Status: CLOSED DUPLICATE of bug 1591156
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
: 1576919 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 17:51 UTC by Kathryn Alexander
Modified: 2018-06-18 14:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-18 14:11:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kathryn Alexander 2018-05-10 17:51:32 UTC
Document URL: https://docs.openshift.com/container-platform/3.9/admin_guide/manage_rbac.html

Section Number and Name: n/a

Describe the issue: You can create cluster roles, not just local roles. The topic makes it sound like you can make only local roles.

Suggestions for improvement: Add steps for creating a cluster role and configuring role aggregation for it. Role aggregation was added in 3.9, so I propose limiting this change to 3.9 and later.

Additional information: The K8 information about making the cluster role should be here: https://kubernetes.io/docs/admin/authorization/rbac/#aggregated-clusterroles. Mo will have more information.

Comment 1 Kathryn Alexander 2018-05-17 18:24:05 UTC
*** Bug 1576919 has been marked as a duplicate of this bug. ***

Comment 4 Kathryn Alexander 2018-06-18 14:11:45 UTC

*** This bug has been marked as a duplicate of bug 1591156 ***


Note You need to log in before you can comment on or make changes to this bug.