Bug 1576935 - [RFE][DR] validator script should also validation for duplicate/empty roles, aaa domains and lun disks
Summary: [RFE][DR] validator script should also validation for duplicate/empty roles, ...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: ovirt-ansible-collection
Classification: oVirt
Component: disaster-recovery
Version: 1.1.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.5.0
: ---
Assignee: Pavel Bar
QA Contact: Avihai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 19:07 UTC by Maor
Modified: 2021-08-24 12:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-24 12:22:03 UTC
oVirt Team: Storage
rule-engine: ovirt-4.3+
sbonazzo: ovirt-4.5?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHV-37772 0 None None None 2021-08-24 12:23:20 UTC

Description Maor 2018-05-10 19:07:04 UTC
Description of problem:
Currently the validator validate if entities exists in setup, such as clusters, affinity groups and affinity labels, it also check for empty target mappings and other missing attributes.
We should fill the missing gaps for roles, domains and lun disks as well.
Also additional validations should be added.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Sandro Bonazzola 2019-01-28 09:36:50 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 3 Eyal Shenitzky 2021-08-24 12:22:03 UTC
This bug/RFE is more than 2 years old and it didn't get enough attention so far, therefore it can be closed. 
Please re-open if this RFE is needed.


Note You need to log in before you can comment on or make changes to this bug.