Bug 1576970 - /usr/bin/acpidump not owned by the package
Summary: /usr/bin/acpidump not owned by the package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: acpica-tools
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Al Stone
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 21:16 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2020-02-24 17:23 UTC (History)
2 users (show)

Fixed In Version: acpica-tools-20180508-2.fc28 acpica-tools-20180508-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-02 20:43:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2018-05-10 21:16:58 UTC
Description of problem:
/usr/bin/acpidump is not owned by the acpica-tools package, hence it's impossible to obtain the tool with "dnf install /usr/bin/acpidump".

Version-Release number of selected component (if applicable):
acpica-tools-20180209-1.fc27.x86_64
$ ls -l /usr/bin/acpidump
lrwxrwxrwx. 1 root root 26 May 10 23:07 /usr/bin/acpidump -> /etc/alternatives/acpidump

How reproducible:
Always.

Steps to Reproduce:
1. dnf install /usr/bin/acpidump
2. dnf install acpica-tools
3. rpm -qf /usr/bin/acpidump

Actual results:
No match for argument: /usr/bin/acpidump
Error: Unable to find a match

file /usr/bin/acpidump is not owned by any package

Expected results:
Successful installation and correct file ownership.

Additional info:
I don't know why this package is using alternatives for the acpidump tool, but the Packaging Guidelines for alternatives do require your package to own the alternativized files (https://fedoraproject.org/wiki/Packaging:Alternatives#How_to_use_alternatives):

If a package is using alternatives, the files which would otherwise conflict MUST be installed with an appropriate suffix (for example: %{_sbindir}/sendmail.postfix instead of %{_sbindir}/sendmail), the original locations MUST be touched (for example: touch %{_sbindir}/sendmail), the links set up by alternatives MUST be listed as %ghost in the file list and proper Requires: MUST be added, like in the examples below.

Putting the alternativized files in the file list ensures that they are owned by respective packages, which means that commands like:

    rpm -qf /usr/bin/foo
    yum install /usr/bin/foo
    repoquery --whatprovides /usr/bin/foo

all work properly. Using %ghost for this purpose allows using globs and generated file lists.

Comment 1 Dominik 'Rathann' Mierzejewski 2018-05-10 21:20:35 UTC
It looks like pmtools used to provide acpidump and acpiextract, but it was retired in F20+ and it's dead upstream (website no longer resolves in DNS), so maybe it's time to stop doing alternatives here?

Comment 2 Al Stone 2018-05-11 00:09:25 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #1)
> It looks like pmtools used to provide acpidump and acpiextract, but it was
> retired in F20+ and it's dead upstream (website no longer resolves in DNS),
> so maybe it's time to stop doing alternatives here?

Perhaps so.  There is an acpidump in the kernel source tree, but in theory it's the same code; acpiextract I *think* has always been part of ACPICA, but the packaging has changed quite a bit.  I have not looked at either of these topics in a while but will do so again.  Thanks for the reminder!

Comment 3 Fedora Update System 2018-05-15 21:01:00 UTC
acpica-tools-20180508-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3767c8c9da

Comment 4 Fedora Update System 2018-05-15 21:01:21 UTC
acpica-tools-20180508-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-61076aa862

Comment 5 Fedora Update System 2018-05-16 01:33:39 UTC
acpica-tools-20180508-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3767c8c9da

Comment 6 Fedora Update System 2018-05-16 03:27:59 UTC
acpica-tools-20180508-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-61076aa862

Comment 7 Fedora Update System 2018-05-22 19:38:07 UTC
acpica-tools-20180508-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c8f3be3336

Comment 8 Fedora Update System 2018-05-22 19:38:26 UTC
acpica-tools-20180508-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-bc16c6f899

Comment 9 Fedora Update System 2018-05-23 16:20:22 UTC
acpica-tools-20180508-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c8f3be3336

Comment 10 Fedora Update System 2018-05-23 17:37:39 UTC
acpica-tools-20180508-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-bc16c6f899

Comment 11 Fedora Update System 2018-06-02 20:43:30 UTC
acpica-tools-20180508-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2018-06-02 21:05:30 UTC
acpica-tools-20180508-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.