Bug 1576973 - Different jdk versions on ambari images generated by sahara-image-pack and sahara-image-create leads to cluster creation failure
Summary: Different jdk versions on ambari images generated by sahara-image-pack and sa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 13.0 (Queens)
Assignee: Telles Nobrega
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 21:23 UTC by Luigi Toscano
Modified: 2018-06-27 13:56 UTC (History)
5 users (show)

Fixed In Version: openstack-sahara-8.0.1-0.20180328233740.36531cb.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:55:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack Storyboard 2002003 0 None None None 2018-05-10 21:23:52 UTC
OpenStack gerrit 567949 0 None stable/queens: MERGED sahara: Fixing java version for Ambari (I78da2fb94b0e8a362c7b4daae166849974682960) 2018-05-14 15:46:35 UTC
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:56:36 UTC

Description Luigi Toscano 2018-05-10 21:23:52 UTC
Description of problem:

There is a mismatch between the jdk version handled during provisioning of Ambari instances:
- sahara-image-pack pre-loads java-1.7.0-openjdk-devel
- sahara-image-create pre-loads java-1.8.0-openjdk-devel

On the other side, sahara-engine (the service) uses the same code of sahara-image-pack and tries to ensure that java-1.7.0-openjdk-devel is installed.

This means that, if the instance is generated using sahara-image-create has no repositories configured, the creation of the cluster will fail.

This is not a total blocker because a workaround exists: an instance generated with sahara-image-create should be tuned to point to a repository with the packages, or the package java-1.7.0-openjdk-devel should be pre-loaded.

Instead, all images should use java-1.8.0-openjdk{,-devel}.

Nevertheless, it is a regression in the behavior of the images produced with sahara-image-create (the only way to produce images before 13) and  it could be nice to have it fixed before the final release.

Version-Release number of selected component (if applicable):
Image generated with:
sahara-image-elements-8.0.1-0.20180316135145.c235e1e.el7ost

OpenStack deployment using:
openstack-sahara-8.0.1-0.20180328233739.36531cb.el7ost

Comment 6 Luigi Toscano 2018-05-17 16:38:32 UTC
sahara-image-pack now injects java 1.8 and this is the version checked during the startup process.

Verified with:
openstack-sahara-image-8.0.1-0.20180328233740.36531cb.el7ost

Comment 7 Luigi Toscano 2018-05-17 16:40:01 UTC
Small typo

(In reply to Luigi Toscano from comment #6)

> Verified with (source package):
> openstack-sahara-8.0.1-0.20180328233740.36531cb.el7ost

Comment 10 errata-xmlrpc 2018-06-27 13:55:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.