Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1577012 - cannot remove stale libvirt-daemon
Summary: cannot remove stale libvirt-daemon
Keywords:
Status: CLOSED DUPLICATE of bug 1558648
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 02:09 UTC by Chris Murphy
Modified: 2018-05-11 06:53 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-11 06:51:46 UTC
Type: Bug


Attachments (Terms of Use)
dnf -vvv remove --duplicates (5.56 KB, text/plain)
2018-05-11 02:09 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2018-05-11 02:09:30 UTC
Created attachment 1434634 [details]
dnf -vvv remove --duplicates

Description of problem:

A normal 'dnf update' had a single failure with libvirt-daemon resulting in two copies installed

libvirt-daemon-4.1.0-1.fc28.x86_64
libvirt-daemon-4.1.0-2.fc28.x86_64

Neither 'dnf remove libvirt-daemon-4.1.0-1.fc28.x86_64' nor 'dnf remove --duplicates' succeeds.

                                                                                                                                     


Version-Release number of selected component (if applicable):


How reproducible:
Well now that I'm stuck with two copies, always reproducible remove failure. How it got into this state in the first place is untested, 1 for 1.

Steps to Reproduce:
1. dnf remove --duplicates
2.
3.

Actual results:

[chris@f28m ~]$ sudo dnf remove --duplicates
Last metadata expiration check: 1:00:03 ago on Thu 10 May 2018 07:00:09 PM MDT.
Dependencies resolved.
=============================================================================================================================================================================
 Package                                       Arch                                  Version                                     Repository                             Size
=============================================================================================================================================================================
Reinstalling:
 libvirt-daemon                                x86_64                                4.1.0-2.fc28                                fedora                                707 k
     replacing  libvirt-daemon.x86_64 4.1.0-1.fc28

Transaction Summary
=============================================================================================================================================================================

Total download size: 707 k
Is this ok [y/N]: y
Downloading Packages:
libvirt-daemon-4.1.0-2.fc28.x86_64.rpm                                                                                                       825 kB/s | 707 kB     00:00    
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                        548 kB/s | 707 kB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                     1/1 
  Running scriptlet: libvirt-daemon-4.1.0-2.fc28.x86_64                                                                                                                  1/1 
  Running scriptlet: libvirt-daemon-4.1.0-2.fc28.x86_64                                                                                                                  1/3 
  Reinstalling     : libvirt-daemon-4.1.0-2.fc28.x86_64                                                                                                                  1/3 
  Running scriptlet: libvirt-daemon-4.1.0-2.fc28.x86_64                                                                                                                  1/3 
  Running scriptlet: libvirt-daemon-4.1.0-1.fc28.x86_64                                                                                                                  2/3 
/var/tmp/rpm-tmp.n0mILJ: line 6: virtlogd.socket: command not found
error: %preun(libvirt-daemon-4.1.0-1.fc28.x86_64) scriptlet failed, exit status 127
Error in PREUN scriptlet in rpm package libvirt-daemon
Error in PREUN scriptlet in rpm package libvirt-daemon
  Running scriptlet: libvirt-daemon-4.1.0-2.fc28.x86_64                                                                                                                  3/3 
error: libvirt-daemon-4.1.0-1.fc28.x86_64: erase failed
  Erasing          : libvirt-daemon-4.1.0-2.fc28.x86_64                                                                                                                  3/3 
  Running scriptlet: libvirt-daemon-4.1.0-2.fc28.x86_64                                                                                                                  3/3 
  Verifying        : libvirt-daemon-4.1.0-2.fc28.x86_64                                                                                                                  1/3 
libvirt-daemon-4.1.0-1.fc28.x86_64 was supposed to be removed but is not!
  Verifying        : libvirt-daemon-4.1.0-1.fc28.x86_64                                                                                                                  2/3 
  Verifying        : libvirt-daemon-4.1.0-2.fc28.x86_64                                                                                                                  3/3 

Failed:
  libvirt-daemon.x86_64 4.1.0-2.fc28                                                                                                                                         

Error: Transaction failed



Expected results:

Should remove.

Additional info:

No idea if this is a packaging or dnf bug though.

Attaching -vvv

Comment 1 Jiri Denemark 2018-05-11 06:51:46 UTC

*** This bug has been marked as a duplicate of bug 1558648 ***

Comment 2 Jiri Denemark 2018-05-11 06:53:27 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=1558648#c5 for upgrade
instructions from libvirt-daemon-4.1.0-1.fc28.


Note You need to log in before you can comment on or make changes to this bug.