Bug 1577038 - Cockpit don't validate the engine vm ip prefix
Summary: Cockpit don't validate the engine vm ip prefix
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.4
: 0.11.25
Assignee: Phillip Bailey
QA Contact: Yihui Zhao
URL:
Whiteboard:
Depends On:
Blocks: cockpit-ovirt-0.11.28
TreeView+ depends on / blocked
 
Reported: 2018-05-11 03:47 UTC by Yihui Zhao
Modified: 2018-06-26 08:40 UTC (History)
13 users (show)

Fixed In Version: cockpit-ovirt-0.11.25-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:40:17 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
yzhao: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91289 0 master MERGED wizard: Validate VM IP CIDR prefix 2018-05-17 12:10:22 UTC
oVirt gerrit 91349 0 ovirt-4.2 MERGED wizard: Validate VM IP CIDR prefix 2018-05-17 12:10:37 UTC

Description Yihui Zhao 2018-05-11 03:47:18 UTC
Description of problem:
Cockpit don't validate the engine vm ip prefix.

Version-Release number of selected component (if applicable):
rhvh-4.2.3.0-0.20180508.0+1
ovirt-hosted-engine-setup-2.2.20-1.el7ev.noarch
cockpit-ovirt-dashboard-0.11.24-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.11-1.el7ev.noarch
rhvm-appliance-4.2-20180504.0.el7.noarch

How reproducible:
100%


Steps to Reproduce:
1. Deploy HE with static ip via cockpit
2. Input the VM ip prefix field, like input '33'

Actual results:
After step2, cockpit don't validate this field.
Expected results:
Cockpit should validate the engine vm ip prefix field.

Additional info:

Comment 1 Yihui Zhao 2018-05-30 01:39:04 UTC
Tested with cockpit-ovirt-0.11.25-1:
Now the engine vm ip prefix validate the input field (0-32)

If not range 0~32, will give the hint "Value must be between 0 and 32"

So, change the bug's status to verified.

Comment 2 Sandro Bonazzola 2018-06-26 08:40:17 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.