Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1577039 - The DNS server plus button is still clicked when it displays disabled from cockpit using Chrome
Summary: The DNS server plus button is still clicked when it displays disabled from co...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.3.3
: 0.12.6
Assignee: Parth Dhanjal
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 03:50 UTC by Yihui Zhao
Modified: 2019-04-16 13:58 UTC (History)
14 users (show)

Fixed In Version: cockpit-ovirt-0.12.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-16 13:58:32 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.3+
godas: devel_ack+
yzhao: testing_ack+


Attachments (Terms of Use)
issue1 (15.09 KB, image/png)
2018-05-11 03:50 UTC, Yihui Zhao
no flags Details
issue2 (1.23 MB, image/jpeg)
2018-05-11 03:51 UTC, Yihui Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 94651 0 master MERGED Disabling the Add Icon along with the Button for DNS Servers option The DNS Server add button was still clicking even th... 2018-12-10 09:10:17 UTC
oVirt gerrit 96101 0 ovirt-4.2 MERGED Disabling the Add Icon along with the Button for DNS Servers option The DNS Server add button was still clicking even th... 2018-12-21 11:06:38 UTC
oVirt gerrit 97575 0 master MERGED Disabling the add icon under the DNS Server tab The disable property was added to the classNames initially. This was cau... 2019-03-18 07:05:00 UTC
oVirt gerrit 98612 0 ovirt-4.3 MERGED Disabling the add icon under the DNS Server tab The disable property was added to the classNames initially. This was cau... 2019-03-18 08:21:47 UTC

Description Yihui Zhao 2018-05-11 03:50:24 UTC
Created attachment 1434741 [details]
issue1

Description of problem:
The DNS server plus button is still clicked when it display disabled from cockpit using Chrome

Version-Release number of selected component (if applicable):
rhvh-4.2.3.0-0.20180508.0+1
ovirt-hosted-engine-setup-2.2.20-1.el7ev.noarch
cockpit-ovirt-dashboard-0.11.24-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.11-1.el7ev.noarch
rhvm-appliance-4.2-20180504.0.el7.noarch
google-chrome-stable-66.0.3359.117-1.x86_64

How reproducible:
100%


Steps to Reproduce:
1. Deploy HE with static ip via cockpit
2. Click the DNS server plus button when it displays disabled

Actual results:
After step2, the DNS server plus button is still clicked when it displays disabled from cockpit using Chrome

Expected results:
After step2, the DNS server plus button shouldn't be  clicked when it displays disabled from cockpit using Chrome

Additional info:
Works well with FireFox

Comment 1 Yihui Zhao 2018-05-11 03:51:43 UTC
Created attachment 1434742 [details]
issue2

Comment 2 Ryan Barry 2018-05-11 03:54:30 UTC
Does this have any functional impact?

Comment 3 Yihui Zhao 2018-05-11 03:58:30 UTC
(In reply to Ryan Barry from comment #2)
> Does this have any functional impact?

I think no, just shouldn't be clicked when it displays disabled, see the attachment.

Also, with firefox, don't meet this issue.

Comment 4 Phillip Bailey 2018-06-11 11:12:21 UTC
This is due to an issue in React [1]. It has been fixed in newer versions, so upgrading the packages should fix it. I'll work on that.



[1] https://github.com/facebook/react/issues/8308

Comment 5 Sandro Bonazzola 2018-12-03 13:13:29 UTC
Moving to gluster team since they're handling the fix.

Comment 6 Wei Wang 2019-01-11 10:28:50 UTC
Retest with redhat-virtualization-host-4.3-20190109.0.el7_6.x86_64.liveimg.squashfs, there is a new bug occurs BZ-1665419.
After BZ-1665419 fixed, I will verify this issue.

Comment 7 Wei Wang 2019-01-17 01:29:47 UTC
Test Version:
redhat-virtualization-host-4.3-20190115.1.el7_6.x86_64.liveimg.squashfs
cockpit-176-4.el7.x86_64
cockpit-machines-ovirt-176-4.el7.noarch
cockpit-bridge-176-4.el7.x86_64
cockpit-storaged-176-4.el7.noarch
cockpit-ovirt-dashboard-0.12.0-1.el7ev.noarch
cockpit-dashboard-176-4.el7.x86_64
cockpit-system-176-4.el7.noarch
cockpit-ws-176-4.el7.x86_64
ovirt-hosted-engine-ha-2.3.0-1.el7ev.noarch
ovirt-hosted-engine-setup-2.3.2-1.el7ev.noarch
google-chrome-stable-68.0.3440.106-1.x86_64

Test Steps:
According to comment 0

Result:
1. The DNS server plus button is not clicked when it displays disabled from cockpit using Chrome. 
2. There still has a tiny issue, the plug button displays focused when it is clicked. 
   This action is different with that on the Firefox browser, and different with the action of minus button.

So change the bug status to "ASSIGNED"

Comment 8 Sandro Bonazzola 2019-01-28 09:44:17 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 9 Gobinda Das 2019-02-27 11:19:56 UTC
Moving this to ovirt-4.3.2 as ovirt-4.3.1 already released.

Comment 10 Sandro Bonazzola 2019-03-22 11:50:54 UTC
Referenced patch oVirt gerrit 98612 was not included in 4.3.2, re-targeting to 4.3.3

Comment 11 Wei Wang 2019-03-28 01:26:27 UTC
Test Version
rhvh-4.3.0.5-0.20190327.0
cockpit-system-176-4.el7.noarch
cockpit-ws-176-4.el7.x86_64
cockpit-bridge-176-4.el7.x86_64
cockpit-storaged-176-4.el7.noarch
cockpit-ovirt-dashboard-0.12.6-1.el7ev.noarch
cockpit-machines-ovirt-176-4.el7.noarch
cockpit-dashboard-176-4.el7.x86_64
cockpit-176-4.el7.x86_64

Test Steps:
1. According to comment 0
2. Compared with the action with Firefox browser.

Result:
The DNS server plus button is not clicked and no focused when it displays disabled from cockpit using Chrome. Same as that on Firefox browser.


Bug is fixed, change the status to "VERIFIED"

Comment 12 Sandro Bonazzola 2019-04-16 13:58:32 UTC
This bugzilla is included in oVirt 4.3.3 release, published on April 16th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.