Bug 1577061 - texstudio 2.12.8-4.fc28 can't be installed
Summary: texstudio 2.12.8-4.fc28 can't be installed
Alias: None
Product: Fedora
Classification: Fedora
Component: texstudio
Version: 28
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: hannes
QA Contact: Fedora Extras Quality Assurance
Depends On: 1577224
TreeView+ depends on / blocked
Reported: 2018-05-11 06:41 UTC by Basil Eric Rabi
Modified: 2018-05-24 20:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2018-05-24 20:38:53 UTC
Type: Bug

Attachments (Terms of Use)

Description Basil Eric Rabi 2018-05-11 06:41:33 UTC
Description of problem:
texstudio 2.12.8-4.fc28 can't be installed

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. sudo dnf upgrade texstudio --enablerepo=updates-testing

Actual results:
Error: Transaction check error:
  file /usr/share/texlive/texmf-dist/tex/latex/preview/preview.sty from install of texlive-preview-6:svn38865-42.fc28.2.noarch conflicts with file from package tex-preview-12.1-3.fc28.noarch

Expected results:
texstudio is installed

Comment 1 hannes 2018-05-11 13:48:43 UTC
This rather seems to be a bug in the packaging of texlive-preview or tex-preview, which is part of emacs-auctex-12.1-3.fc28.src.rpm.

Comment 2 hannes 2018-05-11 13:57:07 UTC
I opened bug https://bugzilla.redhat.com/show_bug.cgi?id=1577224. In the mean time, please just remove the package tex-preview and install the texlive-preview one. Hope that this is fixed pretty quick.

Comment 3 Robert Holmes 2018-05-12 02:11:47 UTC
That workaround is not very satisfactory; tex-preview is a dependency of both 


so it requires the removal of upwards of 3000 packages (i.e., the entire texlive collection, plus whatever depends on it).

Comment 4 hannes 2018-05-12 06:14:12 UTC
As I said, I can't do more to solve the issue, since it just is a packaging issue in the other two packages. For me this worked, since I didn't have these two packages, and their dependencies, installed.

Comment 5 Christian Dersch 2018-05-12 07:58:51 UTC
Removing texlive-collection-latexextra does not force the removal of other packages as it is a meta package. Worked for me. For emacs-auctex we have to wait for the fix in the packaging :( I also don't see any other solution here.

Comment 6 R Jenssen 2018-05-14 02:01:44 UTC
Package gnuplot-latex depends on tex-preview:

 gnuplot-latex         noarch         5.0.6-8.fc28         fedora          80 k
Installing dependencies:
 tex-preview           noarch         12.1-3.fc28          fedora          69 k

Note You need to log in before you can comment on or make changes to this bug.