Bug 1577121 - [ALL_LANG] The language list format in the drop-down on the welcome page should be consistent
Summary: [ALL_LANG] The language list format in the drop-down on the welcome page sho...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.3.5
Hardware: All
OS: Linux
medium
low vote
Target Milestone: ovirt-4.4.7
: 4.4.7
Assignee: Sharon Gratch
QA Contact: Ivana Saranova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 08:48 UTC by Bhushan Barve
Modified: 2021-07-06 07:28 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.4.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 07:28:20 UTC
oVirt Team: UX
sgratch: ovirt-4.4?
bbarve: planning_ack?
sgratch: devel_ack+
gdeolive: testing_ack+


Attachments (Terms of Use)
language list on welcome page (122.45 KB, image/png)
2018-05-11 08:48 UTC, Bhushan Barve
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github oVirt ovirt-web-ui pull 1425 0 None open Update locales list on account settings dialog 2021-05-09 16:59:37 UTC
oVirt gerrit 114711 0 master MERGED core: keep persistency of available languages on landing page 2021-05-11 14:28:39 UTC

Description Bhushan Barve 2018-05-11 08:48:44 UTC
Created attachment 1434811 [details]
language list on welcome page

Description of problem: For most of the languages, the list maintains language - region format. For e.g. Deutsch - Deutschland. However, for few ones, the same format is not maintained. Following are the same -
Cesky
U.S.English
Portugues do Brazil

So the language list should be consistent for all of them. Please refer attached screenshot.

Currently following languages are listed in the language selection drop-down on the welcome page - 


Version-Release number of selected component (if applicable):
Version 4.2.3.5-0.1.el7

How reproducible:
always

Steps to Reproduce:
1. Access the welcome page
2. Click on the language drop-down
3. Observe the languages like Cesky, U.S.English, Portugues do Brazil

Actual results:
The mentioned languages do not have language - region format like others.

Expected results:
All languages should have the same language - region format.

Additional info:.
This request has come from our L10N QA vendor.

Comment 1 Yuko Katabami 2020-11-21 02:00:10 UTC
Hi @sandro.bonazzola@gmail.com I checked this in 4.4.3.5-0.5.el8ev and confirmed that it is not fixed yet.
Could you assign this to the relevant engineering team?

Comment 2 Sandro Bonazzola 2020-11-26 10:39:37 UTC
Sharon can you please have a look?

Comment 3 Sharon Gratch 2021-01-11 10:16:46 UTC
Sure, targeting to 4.4.5.

Comment 4 Ivana Saranova 2021-06-22 11:28:42 UTC
Steps to Reproduce:
1. Access the welcome page
2. Click on the language drop-down
3. Observe the languages like Cesky, U.S.English, Portugues do Brazil

Results:
All languages have the same language-region format.

Verified in:
ovirt-engine-4.4.7.1-0.9.el8ev.noarch

Comment 5 Sandro Bonazzola 2021-07-06 07:28:20 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.