Bug 1577136 - Unmanaged Primary Interface can have a subnet record with incorrect range
Summary: Unmanaged Primary Interface can have a subnet record with incorrect range
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Networking
Version: 6.3.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2018-05-11 09:35 UTC by Nikola Kresic
Modified: 2020-01-15 20:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-15 20:29:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1576859 0 high CLOSED [RFE] Implement automatic assigning subnets through data provided by facter 2021-02-22 00:41:40 UTC

Description Nikola Kresic 2018-05-11 09:35:55 UTC
Description of problem:
Currently Sat6 forces that the Primary interface must have a Subnet. But if the Primary interface is unmanaged it justs adds a subnet and does not care if the range is matching.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:

Reproducution 1:
- Create 2 Subnets
  Primary 192.168.10.x
  Kickstart 192.168.20.x, make this having the Capusle / TFTP
-  Create/Register a HostA with 2 interfaces
     NIC1: Primary Interface 192.168.10.x
     NIC2: Kickstart interface 192.168.20.x
- Edit HostA interfaces
- Set the Subnet of Primary interface to Provisioning Subnet 192.168.20.x
- UnCheck the  'Managed' to disable validation
- Submit changes


Actual results:

HostA saved

Now let Sat6 decide itself:
- Edit HostA interfaces
- Delete Subnet of the Primary interface 
- Keep the 'Managed' unchecked.
- Submit changes

Expected results:

Either the unmanaged interface fails or we have a way to tell the Satellite which subnet is which, so it doesnt make these kind of mistakes

Additional info:

Ive opened a similar RFE BZ where i asked for a way for Sat to read the Facter data to provision the interfaces. This way if that RFE is accepted, we can combine the two issues. Do not allow for some random subnet assignment, and wait
for Facter data to deliver actual interface data. Please check BZ #1576859

Comment 2 Bryan Kearney 2019-12-03 16:34:25 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 3 Bryan Kearney 2020-01-15 20:29:52 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.

Comment 4 Bryan Kearney 2020-01-15 20:30:06 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.